Browse Source

php7-pecl-http: fix build for big endian (fixes #3691)

While at, improve pre-seeded dependency detection.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lilik-openwrt-22.03
Michael Heimpold 8 years ago
parent
commit
333957fba9
3 changed files with 16 additions and 2 deletions
  1. +2
    -2
      lang/php7-pecl-http/Makefile
  2. +11
    -0
      lang/php7-pecl-http/patches/100_php_http_etag_bigendian_check.patch
  3. +3
    -0
      lang/php7/pecl.mk

+ 2
- 2
lang/php7-pecl-http/Makefile View File

@ -32,8 +32,8 @@ include $(INCLUDE_DIR)/nls.mk
include ../php7/pecl.mk
CONFIGURE_VARS+= \
PHP_PROPRO=yes \
PHP_RAPHF=yes \
PECL_cv_HAVE_EXT_propro=yes \
PECL_cv_HAVE_EXT_raphf=yes \
PECL_cv_HAVE_LIBCURL_ARES=no \
PECL_cv_HAVE_LIBCURL_OpenSSL=$(if $(CONFIG_LIBCURL_OPENSSL),yes,no) \
PECL_cv_HAVE_LIBCURL_GnuTLS=$(if $(CONFIG_LIBCURL_GNUTLS),yes,no) \


+ 11
- 0
lang/php7-pecl-http/patches/100_php_http_etag_bigendian_check.patch View File

@ -0,0 +1,11 @@
--- a/src/php_http_etag.c 2016-12-12 10:04:21.000000000 +0100
+++ b/src/php_http_etag.c 2016-12-23 21:10:59.523222367 +0100
@@ -60,7 +60,7 @@
unsigned char buf[4];
*((uint *) e->ctx) = ~*((uint *) e->ctx);
-#if WORDS_BIGENDIAN
+#ifdef WORDS_BIGENDIAN
etag = php_http_etag_digest((unsigned char *) e->ctx, 4);
#else
buf[0] = ((unsigned char *) e->ctx)[3];

+ 3
- 0
lang/php7/pecl.mk View File

@ -16,6 +16,9 @@ define Build/Prepare
( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/usr/bin/phpize7 )
endef
CONFIGURE_VARS+= \
ac_cv_c_bigendian_php=$(if $(CONFIG_BIG_ENDIAN),yes,no)
CONFIGURE_ARGS+= \
--with-php-config=$(STAGING_DIR)/usr/bin/php7-config


Loading…
Cancel
Save