Browse Source

libglog: remove

Was used by libfolly.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
3106071c28
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 0 additions and 85 deletions
  1. +0
    -48
      libs/libglog/Makefile
  2. +0
    -13
      libs/libglog/patches/100-fix-musl-compilation.patch
  3. +0
    -24
      libs/libglog/patches/110-nanosleep.patch

+ 0
- 48
libs/libglog/Makefile View File

@ -1,48 +0,0 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=glog
PKG_VERSION:=0.4.0
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/google/glog/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=f28359aeba12f30d73d9e4711ef356dc842886968112162bc73002645139c39c
PKG_MAINTAINER:=Amir Sabbaghi <asaba90@gmail.com>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
CMAKE_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/glog
SECTION:=libs
CATEGORY:=Libraries
TITLE:=C++ implementation of the Google logging module
DEPENDS:=+libstdcpp +libpthread +gflags
URL:=https://github.com/google/glog
endef
define Package/glog/description
This repository contains a C++ implementation of the Google logging
module. Documentation for the implementation is in doc/.
endef
CMAKE_OPTIONS += \
-DBUILD_SHARED_LIBS=ON \
-DBUILD_TESTING=OFF \
-DUNWIND_LIBRARY=OFF
TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
TARGET_CFLAGS += -Wl,--gc-sections
define Package/glog/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libglog.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,glog))

+ 0
- 13
libs/libglog/patches/100-fix-musl-compilation.patch View File

@ -1,13 +0,0 @@
Index: glog-0.4.0/src/symbolize_unittest.cc
===================================================================
--- glog-0.4.0.orig/src/symbolize_unittest.cc
+++ glog-0.4.0/src/symbolize_unittest.cc
@@ -401,7 +401,7 @@ int main(int argc, char **argv) {
FLAGS_logtostderr = true;
InitGoogleLogging(argv[0]);
InitGoogleTest(&argc, argv);
-#if defined(HAVE_SYMBOLIZE)
+#if defined(HAVE_SYMBOLIZE) && defined(HAVE_STACKTRACE)
# if defined(__ELF__)
// We don't want to get affected by the callback interface, that may be
// used to install some callback function at InitGoogle() time.

+ 0
- 24
libs/libglog/patches/110-nanosleep.patch View File

@ -1,24 +0,0 @@
From d7b02b6929baf5b21ee6e15a700b4fc82d962e9c Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Thu, 25 Jul 2019 19:14:42 -0700
Subject: [PATCH] googletest: Switch to nanosleep
usleep is deprecated and optionally not available with uClibc-ng.
---
src/googletest.h | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/googletest.h b/src/googletest.h
index 49ddbc0a..39fb29fb 100644
--- a/src/googletest.h
+++ b/src/googletest.h
@@ -574,7 +574,8 @@ class Thread {
static inline void SleepForMilliseconds(int t) {
#ifndef OS_WINDOWS
- usleep(t * 1000);
+ const struct timespec req = {0, t * 1000 * 1000};
+ nanosleep(&req, NULL);
#else
Sleep(t);
#endif

Loading…
Cancel
Save