Browse Source
Merge pull request #13071 from neheb/quot
quota: fix compilation without sys/cdefs
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
19 additions and
1 deletions
-
utils/quota/Makefile
-
utils/quota/patches/010-cdefs.patch
|
|
@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=quota |
|
|
|
PKG_VERSION:=4.05 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
PKG_RELEASE:=3 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=@SF/linuxquota |
|
|
|
|
|
@ -0,0 +1,18 @@ |
|
|
|
--- a/quota.h
|
|
|
|
+++ b/quota.h
|
|
|
|
@@ -1,7 +1,6 @@
|
|
|
|
#ifndef GUARD_QUOTA_H |
|
|
|
#define GUARD_QUOTA_H |
|
|
|
|
|
|
|
-#include <sys/cdefs.h>
|
|
|
|
#include <sys/types.h> |
|
|
|
#include <stdint.h> |
|
|
|
|
|
|
|
@@ -182,6 +181,6 @@ enum {
|
|
|
|
#endif |
|
|
|
#endif |
|
|
|
|
|
|
|
-long quotactl __P((int, const char *, qid_t, caddr_t));
|
|
|
|
+long quotactl (int, const char *, qid_t, caddr_t);
|
|
|
|
|
|
|
|
#endif /* _QUOTA_ */ |