Remove upstreamed patches. Switch to AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>lilik-openwrt-22.03
@ -1,37 +0,0 @@ | |||||
From 40c5681ab92e7db1298273ccf3c816e6a1498260 Mon Sep 17 00:00:00 2001 | |||||
From: Werner Lemberg <wl@gnu.org> | |||||
Date: Mon, 26 Oct 2020 18:09:56 +0100 | |||||
Subject: [PATCH] * meson.build: Fix 'harfbuzz' and 'brotli' build options | |||||
(#59347). | |||||
Without this patch, 'harfbuzz' and 'brotli' are always required. | |||||
Patch submitted anonymously in Savannah bug report. | |||||
--- | |||||
meson.build | 12 ++++++++---- | |||||
1 file changed, 8 insertions(+), 4 deletions(-) | |||||
--- a/meson.build | |||||
+++ b/meson.build | |||||
@@ -267,13 +267,17 @@ ft2_deps += [libpng_dep] | |||||
harfbuzz_dep = dependency('harfbuzz', | |||||
version: '>= 1.8.0', | |||||
required: get_option('harfbuzz')) | |||||
-ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_HARFBUZZ'] | |||||
-ft2_deps += [harfbuzz_dep] | |||||
+if harfbuzz_dep.found() | |||||
+ ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_HARFBUZZ'] | |||||
+ ft2_deps += [harfbuzz_dep] | |||||
+endif | |||||
# Brotli decompression support | |||||
brotli_dep = dependency('libbrotlidec', required: get_option('brotli')) | |||||
-ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_BROTLI'] | |||||
-ft2_deps += [brotli_dep] | |||||
+if brotli_dep.found() | |||||
+ ftoption_command += ['--enable=FT_CONFIG_OPTION_USE_BROTLI'] | |||||
+ ft2_deps += [brotli_dep] | |||||
+endif | |||||
# We can now generate `ftoption.h`. | |||||
ftoption_h = custom_target('ftoption.h', |
@ -1,11 +0,0 @@ | |||||
--- a/meson.build | |||||
+++ b/meson.build | |||||
@@ -26,7 +26,7 @@ project('freetype2', 'c', | |||||
# running an external command is required. | |||||
python = import('python') | |||||
-python_exe = python.find_installation(required: true) | |||||
+python_exe = 'python3' | |||||
ft2_version = run_command(python_exe, | |||||
files('builds/meson/extract_freetype_version.py'), |
@ -1,56 +0,0 @@ | |||||
From 26e2a89598d69c7aba76c83f6a1fcf1db17574ab Mon Sep 17 00:00:00 2001 | |||||
From: Werner Lemberg <wl@gnu.org> | |||||
Date: Wed, 4 Nov 2020 21:00:22 +0100 | |||||
Subject: [PATCH] * meson.build: Fix .pc file generation. | |||||
For backwards compatibility we need the libtool version, not the .so | |||||
number. | |||||
Reported by Nikolaus. | |||||
Downloaded from upstream commit: | |||||
https://gitlab.freedesktop.org/freetype/freetype/-/commit/26e2a89598d69c7aba76c83f6a1fcf1db17574ab | |||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> | |||||
--- | |||||
ChangeLog | 9 +++++++++ | |||||
meson.build | 10 +++++++--- | |||||
2 files changed, 16 insertions(+), 3 deletions(-) | |||||
--- a/meson.build | |||||
+++ b/meson.build | |||||
@@ -32,11 +32,15 @@ ft2_version = run_command(python_exe, | |||||
files('builds/meson/extract_freetype_version.py'), | |||||
files('include/freetype/freetype.h')).stdout().strip() | |||||
-ft2_libtool_version = run_command(python_exe, | |||||
+ft2_so_version = run_command(python_exe, | |||||
files('builds/meson/extract_libtool_version.py'), | |||||
'--soversion', | |||||
files('builds/unix/configure.raw')).stdout().strip() | |||||
+ft2_libtool_version = run_command(python_exe, | |||||
+ files('builds/meson/extract_libtool_version.py'), | |||||
+ files('builds/unix/configure.raw')).stdout().strip() | |||||
+ | |||||
ft2_includes = include_directories('include') | |||||
@@ -320,7 +324,7 @@ ft2_lib = library('freetype', | |||||
include_directories: ft2_includes, | |||||
dependencies: ft2_deps, | |||||
install: true, | |||||
- version: ft2_libtool_version, | |||||
+ version: ft2_so_version, | |||||
) | |||||
@@ -328,7 +332,7 @@ ft2_lib = library('freetype', | |||||
freetype2_dep = declare_dependency( | |||||
include_directories: ft2_includes, | |||||
link_with: ft2_lib, | |||||
- version: ft2_libtool_version) | |||||
+ version: ft2_so_version) | |||||
# NOTE: Using both `install_dir` and `subdir` doesn't seem to work below, |