Browse Source

forked-daapd: update to 27.2

- update config file to match upstream
- remove patches, not required any more

Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
lilik-openwrt-22.03
Espen Jürgensen 4 years ago
parent
commit
2d1c1da16c
4 changed files with 22 additions and 35 deletions
  1. +3
    -3
      sound/forked-daapd/Makefile
  2. +19
    -2
      sound/forked-daapd/files/forked-daapd.conf
  3. +0
    -10
      sound/forked-daapd/patches/010-errno.patch
  4. +0
    -20
      sound/forked-daapd/patches/020-gcc10.patch

+ 3
- 3
sound/forked-daapd/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=forked-daapd
PKG_VERSION:=27.1
PKG_RELEASE:=3
PKG_VERSION:=27.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
PKG_HASH:=e11f86d7de5b7743e388d88f17adb8967d30c4c6c9b4bee2d85d3e7ee2d1849f
PKG_HASH:=27294a893253d232161f4521fc42147e65324ce5a13fcf550b537100375277bb
PKG_FIXUP:=autoreconf
PKG_USE_MIPS16:=0


+ 19
- 2
sound/forked-daapd/files/forked-daapd.conf View File

@ -47,7 +47,7 @@ general {
# When starting playback, autoselect speaker (if none of the previously
# selected speakers/outputs are available)
# speaker_autoselect = yes
# speaker_autoselect = no
# Most modern systems have a high-resolution clock, but if you are on an
# unusual platform and experience audio drop-outs, you can try changing
@ -157,6 +157,10 @@ library {
# to trigger a rescan.
# filescan_disable = false
# Should metadata from m3u playlists, e.g. artist and title in EXTINF,
# override the metadata we get from radio streams?
# m3u_overrides = false
# Should iTunes metadata override ours?
# itunes_overrides = false
@ -272,7 +276,15 @@ audio {
# path = "/path/to/fifo"
#}
# AirPlay/Airport Express device settings
# AirPlay settings common to all devices
#airplay_shared {
# UDP ports used when airplay devices make connections back to forked-daapd
# (choosing specific ports may be helpful when running forked-daapd behind a firewall)
# control_port = 0
# timing_port = 0
#}
# AirPlay per device settings
# (make sure you get the capitalization of the device name right)
#airplay "My AirPlay device" {
# forked-daapd's volume goes to 11! If that's more than you can handle
@ -288,6 +300,11 @@ audio {
# present. The speaker will remain until restart of forked-daapd.
# permanent = false
# Some devices spuriously disconnect during playback, and based on the
# device type forked-daapd may attempt to reconnect. Setting this option
# overrides this so reconnecting is either always enabled or disabled.
# reconnect = false
# AirPlay password
# password = "s1kr3t"
#}


+ 0
- 10
sound/forked-daapd/patches/010-errno.patch View File

@ -1,10 +0,0 @@
--- a/src/websocket.c
+++ b/src/websocket.c
@@ -25,6 +25,7 @@
#ifdef HAVE_PTHREAD_NP_H
# include <pthread_np.h>
#endif
+#include <errno.h>
#include <stdbool.h>
#include <stdio.h>
#include <string.h>

+ 0
- 20
sound/forked-daapd/patches/020-gcc10.patch View File

@ -1,20 +0,0 @@
--- a/src/outputs.h
+++ b/src/outputs.h
@@ -185,7 +185,7 @@ struct output_data
int samples;
};
-struct output_buffer
+static struct output_buffer
{
struct timespec pts;
// The array is two larger than max quality subscriptions because element 0
@@ -262,7 +262,7 @@ struct output_definition
};
// Our main list of devices, not for use by backend modules
-struct output_device *output_device_list;
+static struct output_device *output_device_list;
/* ------------------------------- General use ------------------------------ */

Loading…
Cancel
Save