Browse Source

libs/neon: import from old packages

Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
lilik-openwrt-22.03
Etienne CHAMPETIER 10 years ago
parent
commit
2c21f90b84
2 changed files with 68 additions and 0 deletions
  1. +63
    -0
      libs/neon/Makefile
  2. +5
    -0
      libs/neon/patches/001-automake-compat.patch

+ 63
- 0
libs/neon/Makefile View File

@ -0,0 +1,63 @@
#
# Copyright (C) 2007-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=neon
PKG_VERSION:=0.29.6
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.webdav.org/neon
PKG_MD5SUM:=591e0c82e6979e7e615211b386b8f6bc
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/libneon
SECTION:=libs
CATEGORY:=Libraries
TITLE:=HTTP and WebDAV client library
URL:=http://www.webdav.org/neon/
DEPENDS:=+libopenssl +libexpat
endef
TARGET_CFLAGS += $(FPIC)
TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--with-expat \
--with-ssl="openssl" \
--without-egd \
--without-libproxy \
CONFIGURE_VARS += \
LDFLAGS="$$$$LDFLAGS -lcrypto -lssl"
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/neon-config $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/neon $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libneon.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/neon.pc $(1)/usr/lib/pkgconfig/
$(SED) 's,-I$$$${includedir}/,-I$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/neon-config
$(SED) 's,-L$$$${libdir},,g' $(1)/usr/bin/neon-config
endef
define Package/libneon/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libneon.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libneon))

+ 5
- 0
libs/neon/patches/001-automake-compat.patch View File

@ -0,0 +1,5 @@
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,2 @@
+SUBDIRS = .
+ACLOCAL_AMFLAGS = -I macros

Loading…
Cancel
Save