Browse Source
bfdd: fix compilation with GCC 10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
4 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
19 additions and
1 deletions
-
net/bfdd/Makefile
-
net/bfdd/patches/020-gcc10.patch
|
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=bfdd |
|
|
|
PKG_SOURCE_DATE:=2019-08-22 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
PKG_RELEASE:=3 |
|
|
|
|
|
|
|
PKG_SOURCE_VERSION:=c54534beb524afc3972039f57b56ec65332b43f7 |
|
|
|
PKG_SOURCE_URL:=https://codeload.github.com/rzalamena/bfdd/tar.gz/$(PKG_SOURCE_VERSION)? |
|
|
|
|
|
@ -0,0 +1,18 @@ |
|
|
|
--- a/bfd.h
|
|
|
|
+++ b/bfd.h
|
|
|
|
@@ -299,13 +299,13 @@ typedef struct bfd_state_str_list_s {
|
|
|
|
int type; |
|
|
|
} bfd_state_str_list; |
|
|
|
|
|
|
|
-struct bfd_vrf {
|
|
|
|
+extern struct bfd_vrf {
|
|
|
|
int vrf_id; |
|
|
|
char name[MAXNAMELEN + 1]; |
|
|
|
UT_hash_handle vh; |
|
|
|
} bfd_vrf; |
|
|
|
|
|
|
|
-struct bfd_iface {
|
|
|
|
+extern struct bfd_iface {
|
|
|
|
int vrf_id; |
|
|
|
char ifname[MAXNAMELEN + 1]; |
|
|
|
UT_hash_handle ifh; |