Browse Source

tcsh: fix out of memory error with musl

Since __GLIBC__ is no longer defined under musl, we must hard patch it.

Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
lilik-openwrt-22.03
Nuno Goncalves 9 years ago
parent
commit
2bb6af5101
2 changed files with 15 additions and 1 deletions
  1. +1
    -1
      utils/tcsh/Makefile
  2. +14
    -0
      utils/tcsh/patches/001-sysmalloc.patch

+ 1
- 1
utils/tcsh/Makefile View File

@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tcsh
PKG_VERSION:=6.19.00
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \


+ 14
- 0
utils/tcsh/patches/001-sysmalloc.patch View File

@ -0,0 +1,14 @@
--- a/config_f.h
+++ b/config_f.h
@@ -135,11 +135,7 @@
* This can be much slower and no memory statistics will be
* provided.
*/
-#if defined(__MACHTEN__) || defined(PURIFY) || defined(MALLOC_TRACE) || defined(_OSD_POSIX) || defined(__MVS__) || defined (__CYGWIN__) || defined(__GLIBC__) || defined(__OpenBSD__) || defined(__APPLE__)
# define SYSMALLOC
-#else
-# undef SYSMALLOC
-#endif
/*
* USE_ACCESS Use access(2) rather than stat(2) when POSIX is defined.

Loading…
Cancel
Save