Browse Source

lighttpd: update to lighttpd 1.4.61 release hash

also remove patches incorporated upstream into lighttpd 1.4.61

Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
lilik-openwrt-22.03
Glenn Strauss 3 years ago
committed by Rosen Penev
parent
commit
2b67f2b178
4 changed files with 5 additions and 39 deletions
  1. +3
    -3
      net/lighttpd/Makefile
  2. +1
    -1
      net/lighttpd/files/lighttpd.conf
  3. +1
    -1
      net/lighttpd/patches/010-meson-lua.patch
  4. +0
    -34
      net/lighttpd/patches/020-decls.patch

+ 3
- 3
net/lighttpd/Makefile View File

@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.60
PKG_VERSION:=1.4.61
PKG_RELEASE:=1
# release candidate ~rcX testing; remove for release
#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.60
#PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4.61
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
PKG_HASH:=4bb1dd859e541a3131e5be101557d2e1195b4129d3a849a3a6fbd21fe1c946f0
PKG_HASH:=43f0d63d04a1b7c5b8aab07e0612e44ccad0afc0614bab784c5b019872363432
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=BSD-3-Clause


+ 1
- 1
net/lighttpd/files/lighttpd.conf View File

@ -28,7 +28,7 @@ server.feature-flags += ("server.graceful-shutdown-timeout" => 5)
#include_shell "/usr/share/lighttpd/use-ipv6.pl"
#dir-listing.encoding = "utf-8"
#server.dir-listing = "enable"
#dir-listing.activate = "enable"
include "/etc/lighttpd/mime.conf"
include "/etc/lighttpd/conf.d/*.conf"

+ 1
- 1
net/lighttpd/patches/010-meson-lua.patch View File

@ -14,7 +14,7 @@ Signed-off-by: Glenn Strauss <gstrauss@gluelogic.com>
--- a/src/meson.build
+++ b/src/meson.build
@@ -388,7 +388,7 @@ endif
@@ -390,7 +390,7 @@ endif
liblua = []
if get_option('with_lua')
found_lua = false


+ 0
- 34
net/lighttpd/patches/020-decls.patch View File

@ -1,34 +0,0 @@
From cf4dfbe15ef8ead3a7eda974af7d804d447f00db Mon Sep 17 00:00:00 2001
From: Glenn Strauss <gstrauss@gluelogic.com>
Date: Mon, 4 Oct 2021 09:51:22 -0400
Subject: [PATCH] [core] define __BEGIN_DECLS, __END_DECLS if needed
---
src/first.h | 16 ++++++++++++++++
1 file changed, 16 insertions(+)
--- a/src/first.h
+++ b/src/first.h
@@ -39,6 +39,22 @@
#include <sys/types.h>
#include <stddef.h>
+#ifndef __BEGIN_DECLS
+#ifdef __cplusplus
+#define __BEGIN_DECLS extern "C" {
+#else
+#define __BEGIN_DECLS
+#endif
+#endif
+
+#ifndef __END_DECLS
+#ifdef __cplusplus
+#define __END_DECLS }
+#else
+#define __END_DECLS
+#endif
+#endif
+
#if defined HAVE_STDINT_H
# include <stdint.h>
#elif defined HAVE_INTTYPES_H

Loading…
Cancel
Save