Browse Source
Merge pull request #7893 from neheb/squid
squid: Fix compilation without OpenSSL ENGINE support
lilik-openwrt-22.03
Hannu Nyman
6 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
12 additions and
1 deletions
-
net/squid/Makefile
-
net/squid/patches/010-openssl-engine.patch
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
|
PKG_NAME:=squid |
|
|
PKG_NAME:=squid |
|
|
PKG_VERSION:=4.4 |
|
|
PKG_VERSION:=4.4 |
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
|
PKG_LICENSE:=GPL-2.0 |
|
|
PKG_LICENSE:=GPL-2.0 |
|
|
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr> |
|
|
PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr> |
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
|
|
--- a/src/ssl/support.cc
|
|
|
|
|
|
+++ b/src/ssl/support.cc
|
|
|
|
|
|
@@ -485,7 +485,7 @@ Ssl::Initialize(void)
|
|
|
|
|
|
|
|
|
|
|
|
SQUID_OPENSSL_init_ssl(); |
|
|
|
|
|
|
|
|
|
|
|
-#if HAVE_OPENSSL_ENGINE_H
|
|
|
|
|
|
+#ifndef OPENSSL_NO_ENGINE
|
|
|
|
|
|
if (::Config.SSL.ssl_engine) { |
|
|
|
|
|
ENGINE_load_builtin_engines(); |
|
|
|
|
|
ENGINE *e; |