Signed-off-by: W. Michael Petullo <mike@flyn.org>lilik-openwrt-22.03
@ -0,0 +1,136 @@ | |||||
# | |||||
# Copyright (C) 2009-2011 OpenWrt.org | |||||
# | |||||
# This is free software, licensed under the GNU General Public License v2. | |||||
# See /LICENSE for more information. | |||||
# | |||||
include $(TOPDIR)/rules.mk | |||||
PKG_NAME:=gst1-plugins-ugly | |||||
PKG_VERSION:=1.2.3 | |||||
PKG_RELEASE:=1 | |||||
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> | |||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-ugly-$(PKG_VERSION) | |||||
PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz | |||||
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/ | |||||
PKG_MD5SUM:=7ae60e2f759f58f32af5fcdc3c9193c4 | |||||
PKG_BUILD_DEPENDS:= gstreamer1 gst1-plugins-base liboil | |||||
PKG_CONFIG_DEPENDS:= \ | |||||
CONFIG_PACKAGE_gst1-mod-asf \ | |||||
CONFIG_PACKAGE_gst1-mod-lame \ | |||||
CONFIG_PACKAGE_gst1-mod-mad \ | |||||
CONFIG_PACKAGE_gst1-mod-mpeg2dec \ | |||||
PKG_FIXUP:=autoreconf | |||||
PKG_INSTALL:=1 | |||||
include $(INCLUDE_DIR)/package.mk | |||||
include $(INCLUDE_DIR)/nls.mk | |||||
define Package/gstreamer1/Default | |||||
CATEGORY:=Multimedia | |||||
SECTION:=multimedia | |||||
TITLE:=GStreamer | |||||
URL:=http://gstreamer.freedesktop.org/ | |||||
endef | |||||
define Package/gstreamer1/description/Default | |||||
GStreamer open source multimedia framework | |||||
endef | |||||
define Package/gst1-plugins-ugly | |||||
$(call Package/gstreamer1/Default) | |||||
TITLE+= plugins collection (ugly) | |||||
DEPENDS+= $(GST_DEPENDS) | |||||
endef | |||||
define Package/gts-plugins-ugly/description | |||||
$(call Package/gstreamer1/description/Default) | |||||
. | |||||
This meta package contains only dependencies to the other plugins from | |||||
the ugly plugins collection. | |||||
endef | |||||
GST_COND_SELECT = $(patsubst %,$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),--enable,--disable)-%,$(1)) | |||||
GST_VERSION:=1.0 | |||||
CONFIGURE_ARGS += \ | |||||
--disable-debug \ | |||||
--disable-examples \ | |||||
\ | |||||
--disable-a52dec \ | |||||
--disable-amrnb \ | |||||
--disable-amrwb \ | |||||
$(call GST_COND_SELECT,asf) \ | |||||
--disable-cdio \ | |||||
--disable-dvdlpcmdec \ | |||||
--disable-dvdread \ | |||||
--disable-dvdsub \ | |||||
--disable-iec958 \ | |||||
$(call GST_COND_SELECT,lame) \ | |||||
$(call GST_COND_SELECT,mad) \ | |||||
$(call GST_COND_SELECT,mpeg2dec) \ | |||||
--disable-mpegaudioparse \ | |||||
--disable-mpegstream \ | |||||
--disable-realmedia \ | |||||
--disable-sidplay \ | |||||
--disable-synaesthesia \ | |||||
--disable-twolame \ | |||||
--disable-x264 \ | |||||
\ | |||||
--without-libiconv-prefix \ | |||||
--without-libintl-prefix \ | |||||
EXTRA_LDFLAGS+= \ | |||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \ | |||||
define Package/gst1-plugins-ugly/install | |||||
/bin/true | |||||
endef | |||||
# 1: short name | |||||
# 2: description | |||||
# 3: dependencies on other gstreamer libraries (short name) | |||||
# 4: dependencies on other gstreamer plugins (short name) | |||||
# 5: dependencies on other packages | |||||
define GstBuildPlugin | |||||
GST_DEPENDS += +gst1-mod-$(1) | |||||
define Package/gst1-mod-$(1) | |||||
$(call Package/gstreamer1/Default) | |||||
TITLE+= $(2) plugin (ugly) | |||||
DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5) | |||||
endef | |||||
define Package/gst1-mod-$(1)/description | |||||
$(call Package/gstreamer1/description/Default) | |||||
. | |||||
This package contains the GStreamer $(2) plugin. | |||||
endef | |||||
define Package/gst1-mod-$(1)/install | |||||
$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION) | |||||
( cd $(PKG_INSTALL_DIR); $(CP) \ | |||||
./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \ | |||||
$$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \ | |||||
) | |||||
endef | |||||
$$(eval $$(call BuildPackage,gst1-mod-$(1))) | |||||
endef | |||||
$(eval $(call GstBuildPlugin,asf,ASF demuxer,audio riff rtp rtsp sdp tag,,)) | |||||
$(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),audio,,+lame-lib)) | |||||
$(eval $(call GstBuildPlugin,mad,MP3 decoder (using MAD),audio tag,,+libid3tag +libmad)) | |||||
$(eval $(call GstBuildPlugin,mpeg2dec,MPEG decoder,video,,+libmpeg2)) | |||||
$(eval $(call BuildPackage,gst1-plugins-ugly)) |
@ -0,0 +1,24 @@ | |||||
diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am | |||||
--- gst-plugins-ugly-1.0.7-vanilla/Makefile.am 2013-06-01 19:58:12.400886469 -0500 | |||||
+++ gst-plugins-ugly-1.0.7/Makefile.am 2013-06-01 19:58:33.306059047 -0500 | |||||
@@ -1,7 +1,7 @@ | |||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc | |||||
SUBDIRS = \ | |||||
- gst-libs gst ext docs m4 tests common pkgconfig po | |||||
+ gst-libs gst ext m4 tests common pkgconfig po | |||||
# include before EXTRA_DIST for win32 assignment | |||||
include $(top_srcdir)/common/win32.mak | |||||
diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in | |||||
--- gst-plugins-ugly-1.0.7-vanilla/Makefile.in 2013-06-01 19:58:12.412885994 -0500 | |||||
+++ gst-plugins-ugly-1.0.7/Makefile.in 2013-06-01 19:58:39.810801615 -0500 | |||||
@@ -453,7 +453,7 @@ | |||||
top_srcdir = @top_srcdir@ | |||||
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc | |||||
SUBDIRS = \ | |||||
- gst-libs gst ext docs m4 tests common pkgconfig po | |||||
+ gst-libs gst ext m4 tests common pkgconfig po | |||||
# the MANIFEST contains all win32 related files that should be disted |
@ -0,0 +1,24 @@ | |||||
diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am | |||||
--- gst-plugins-ugly-1.0.7-vanilla/Makefile.am 2013-06-01 19:59:16.988330482 -0500 | |||||
+++ gst-plugins-ugly-1.0.7/Makefile.am 2013-06-01 19:59:28.455876771 -0500 | |||||
@@ -1,7 +1,7 @@ | |||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc | |||||
SUBDIRS = \ | |||||
- gst-libs gst ext m4 tests common pkgconfig po | |||||
+ gst-libs gst ext m4 common pkgconfig po | |||||
# include before EXTRA_DIST for win32 assignment | |||||
include $(top_srcdir)/common/win32.mak | |||||
diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in | |||||
--- gst-plugins-ugly-1.0.7-vanilla/Makefile.in 2013-06-01 19:59:16.988330482 -0500 | |||||
+++ gst-plugins-ugly-1.0.7/Makefile.in 2013-06-01 19:59:39.840426385 -0500 | |||||
@@ -453,7 +453,7 @@ | |||||
top_srcdir = @top_srcdir@ | |||||
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc | |||||
SUBDIRS = \ | |||||
- gst-libs gst ext m4 tests common pkgconfig po | |||||
+ gst-libs gst ext m4 common pkgconfig po | |||||
# the MANIFEST contains all win32 related files that should be disted |
@ -0,0 +1,35 @@ | |||||
diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/configure.ac gst-plugins-ugly-1.0.7/configure.ac | |||||
--- gst-plugins-ugly-1.0.7-vanilla/configure.ac 2013-06-01 19:59:46.199174835 -0500 | |||||
+++ gst-plugins-ugly-1.0.7/configure.ac 2013-06-01 20:00:29.709453831 -0500 | |||||
@@ -479,7 +479,6 @@ | |||||
tests/Makefile | |||||
tests/check/Makefile | |||||
m4/Makefile | |||||
-po/Makefile.in | |||||
pkgconfig/Makefile | |||||
pkgconfig/gstreamer-plugins-ugly-uninstalled.pc | |||||
gst-plugins-ugly.spec | |||||
diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am | |||||
--- gst-plugins-ugly-1.0.7-vanilla/Makefile.am 2013-06-01 19:59:46.210174399 -0500 | |||||
+++ gst-plugins-ugly-1.0.7/Makefile.am 2013-06-01 20:00:11.351179921 -0500 | |||||
@@ -1,7 +1,7 @@ | |||||
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc | |||||
SUBDIRS = \ | |||||
- gst-libs gst ext m4 common pkgconfig po | |||||
+ gst-libs gst ext m4 common pkgconfig | |||||
# include before EXTRA_DIST for win32 assignment | |||||
include $(top_srcdir)/common/win32.mak | |||||
diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in | |||||
--- gst-plugins-ugly-1.0.7-vanilla/Makefile.in 2013-06-01 19:59:46.210174399 -0500 | |||||
+++ gst-plugins-ugly-1.0.7/Makefile.in 2013-06-01 20:00:20.222829049 -0500 | |||||
@@ -453,7 +453,7 @@ | |||||
top_srcdir = @top_srcdir@ | |||||
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc | |||||
SUBDIRS = \ | |||||
- gst-libs gst ext m4 common pkgconfig po | |||||
+ gst-libs gst ext m4 common pkgconfig | |||||
# the MANIFEST contains all win32 related files that should be disted |