Browse Source

znc: update to 1.4

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
lilik-openwrt-22.03
Jonas Gorski 10 years ago
parent
commit
272014632f
2 changed files with 15 additions and 2 deletions
  1. +2
    -2
      net/znc/Makefile
  2. +13
    -0
      net/znc/patches/900-remove_cpp11_usage.patch

+ 2
- 2
net/znc/Makefile View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=znc
PKG_VERSION:=1.2
PKG_VERSION:=1.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://znc.in/releases \
http://znc.in/releases/archive
PKG_MD5SUM:=ef18e5402a82cc3fcab5c2ac5c2e6f3b
PKG_MD5SUM:=630cb74db34d2d5451ba30b47869f6bb
PKG_MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
PKG_LICENSE:=Apache-2.0


+ 13
- 0
net/znc/patches/900-remove_cpp11_usage.patch View File

@ -0,0 +1,13 @@
diff --git a/modules/certauth.cpp b/modules/certauth.cpp
index 61e5687..4857d59 100644
--- a/modules/certauth.cpp
+++ b/modules/certauth.cpp
@@ -204,7 +204,7 @@ public:
return;
}
- SCString::const_iterator it2 = it->second.begin();
+ SCString::iterator it2 = it->second.begin();
while (id > 1) {
++it2;
id--;

Loading…
Cancel
Save