Browse Source

reaver: use 65536 as snaplen with pcap

It should fix issue #3333.  The patch was formed with help from
t6x/reaver-wps-fork-t6x#101

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
lilik-openwrt-22.03
Yousong Zhou 8 years ago
parent
commit
25621beab4
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      net/reaver/Makefile
  2. +11
    -0
      net/reaver/patches/0101-pcap-use-65536-as-snaplen.patch

+ 1
- 1
net/reaver/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=reaver
PKG_VERSION:=1.4
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz


+ 11
- 0
net/reaver/patches/0101-pcap-use-65536-as-snaplen.patch View File

@ -0,0 +1,11 @@
--- a/src/init.c.orig 2016-12-08 13:23:17.386891467 +0800
+++ b/src/init.c 2016-12-08 13:23:20.850892551 +0800
@@ -121,7 +121,7 @@ pcap_t *capture_init(char *capture_sourc
pcap_t *handle = NULL;
char errbuf[PCAP_ERRBUF_SIZE] = { 0 };
- handle = pcap_open_live(capture_source, BUFSIZ, 1, 0, errbuf);
+ handle = pcap_open_live(capture_source, 65536, 1, 0, errbuf);
if(!handle)
{
handle = pcap_open_offline(capture_source, errbuf);

Loading…
Cancel
Save