|
@ -26,7 +26,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an |
|
|
ARG_DISBL_SET([curve25519], [disable Curve25519 Diffie-Hellman plugin.]) |
|
|
ARG_DISBL_SET([curve25519], [disable Curve25519 Diffie-Hellman plugin.]) |
|
|
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.]) |
|
|
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.]) |
|
|
ARG_ENABL_SET([md4], [enable MD4 software implementation plugin.]) |
|
|
ARG_ENABL_SET([md4], [enable MD4 software implementation plugin.]) |
|
|
@@ -1483,6 +1484,7 @@ ADD_PLUGIN([botan], [s ch
|
|
|
|
|
|
|
|
|
@@ -1487,6 +1488,7 @@ ADD_PLUGIN([botan], [s ch
|
|
|
ADD_PLUGIN([af-alg], [s charon scepclient pki scripts medsrv attest nm cmd aikgen]) |
|
|
ADD_PLUGIN([af-alg], [s charon scepclient pki scripts medsrv attest nm cmd aikgen]) |
|
|
ADD_PLUGIN([fips-prf], [s charon nm cmd]) |
|
|
ADD_PLUGIN([fips-prf], [s charon nm cmd]) |
|
|
ADD_PLUGIN([gmp], [s charon scepclient pki scripts manager medsrv attest nm cmd aikgen fuzz]) |
|
|
ADD_PLUGIN([gmp], [s charon scepclient pki scripts manager medsrv attest nm cmd aikgen fuzz]) |
|
@ -34,7 +34,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an |
|
|
ADD_PLUGIN([curve25519], [s charon pki scripts nm cmd]) |
|
|
ADD_PLUGIN([curve25519], [s charon pki scripts nm cmd]) |
|
|
ADD_PLUGIN([agent], [s charon nm cmd]) |
|
|
ADD_PLUGIN([agent], [s charon nm cmd]) |
|
|
ADD_PLUGIN([keychain], [s charon cmd]) |
|
|
ADD_PLUGIN([keychain], [s charon cmd]) |
|
|
@@ -1624,6 +1626,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
|
|
|
|
|
|
|
|
@@ -1628,6 +1630,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
|
|
AM_CONDITIONAL(USE_MGF1, test x$mgf1 = xtrue) |
|
|
AM_CONDITIONAL(USE_MGF1, test x$mgf1 = xtrue) |
|
|
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue) |
|
|
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue) |
|
|
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue) |
|
|
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue) |
|
@ -42,7 +42,7 @@ Subject: [PATCH 904/904] gmpdh: Plugin that implements gmp DH functions in an |
|
|
AM_CONDITIONAL(USE_CURVE25519, test x$curve25519 = xtrue) |
|
|
AM_CONDITIONAL(USE_CURVE25519, test x$curve25519 = xtrue) |
|
|
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue) |
|
|
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue) |
|
|
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue) |
|
|
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue) |
|
|
@@ -1901,6 +1904,7 @@ AC_CONFIG_FILES([
|
|
|
|
|
|
|
|
|
@@ -1905,6 +1908,7 @@ AC_CONFIG_FILES([
|
|
|
src/libstrongswan/plugins/mgf1/Makefile |
|
|
src/libstrongswan/plugins/mgf1/Makefile |
|
|
src/libstrongswan/plugins/fips_prf/Makefile |
|
|
src/libstrongswan/plugins/fips_prf/Makefile |
|
|
src/libstrongswan/plugins/gmp/Makefile |
|
|
src/libstrongswan/plugins/gmp/Makefile |
|
|