Browse Source
xfsprogs: fix compilation with uClibc-ng
MAP_SHARED_VALIDATE is completely missing.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
4 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
6 additions and
2 deletions
-
utils/xfsprogs/Makefile
-
utils/xfsprogs/patches/140-mman.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=xfsprogs |
|
|
|
PKG_VERSION:=5.5.0 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz |
|
|
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs |
|
|
|
|
|
@ -1,12 +1,16 @@ |
|
|
|
--- a/io/mmap.c
|
|
|
|
+++ b/io/mmap.c
|
|
|
|
@@ -11,6 +11,10 @@
|
|
|
|
@@ -11,6 +11,14 @@
|
|
|
|
#include "init.h" |
|
|
|
#include "io.h" |
|
|
|
|
|
|
|
+#ifndef MAP_SYNC
|
|
|
|
+#define MAP_SYNC 0
|
|
|
|
+#endif
|
|
|
|
+
|
|
|
|
+#ifndef MAP_SHARED_VALIDATE
|
|
|
|
+#define MAP_SHARED_VALIDATE 0x03
|
|
|
|
+#endif
|
|
|
|
+
|
|
|
|
static cmdinfo_t mmap_cmd; |
|
|
|
static cmdinfo_t mread_cmd; |
|
|
|