|
|
@ -1,18 +1,18 @@ |
|
|
|
--- a/src/twisted/python/_setup.py
|
|
|
|
+++ b/src/twisted/python/_setup.py
|
|
|
|
@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
|
|
|
|
|
|
|
|
@@ -173,11 +173,6 @@ class ConditionalExtension(Extension, ob
|
|
|
|
# The C extensions used for Twisted. |
|
|
|
_EXTENSIONS = [ |
|
|
|
- ConditionalExtension(
|
|
|
|
ConditionalExtension( |
|
|
|
- "twisted.test.raiser",
|
|
|
|
- sources=["src/twisted/test/raiser.c"],
|
|
|
|
- condition=lambda _: _isCPython),
|
|
|
|
-
|
|
|
|
ConditionalExtension( |
|
|
|
- ConditionalExtension(
|
|
|
|
"twisted.internet.iocpreactor.iocpsupport", |
|
|
|
sources=[ |
|
|
|
@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
|
|
|
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c", |
|
|
|
@@ -241,12 +236,11 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
|
|
|
"incremental >= 16.10.1", |
|
|
|
"Automat >= 0.3.0", |
|
|
|
"hyperlink >= 17.1.1", |
|
|
@ -26,7 +26,7 @@ |
|
|
|
use_incremental=True, |
|
|
|
setup_requires=["incremental >= 16.10.1"], |
|
|
|
install_requires=requirements, |
|
|
|
@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
|
|
|
@@ -256,7 +250,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
|
|
|
cmdclass=command_classes, |
|
|
|
include_package_data=True, |
|
|
|
exclude_package_data={ |
|
|
|