Browse Source

alsa-utils: Update to 1.2.2

Removed upstreamed patch.

Remove other patch and replace with a simple configure variable.

Add another configure variable to avoid linking to libatopology.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
22e8231471
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 8 additions and 54 deletions
  1. +8
    -3
      sound/alsa-utils/Makefile
  2. +0
    -23
      sound/alsa-utils/patches/100-uClibc-compat.patch
  3. +0
    -28
      sound/alsa-utils/patches/101-disable-libsamplerate.patch

+ 8
- 3
sound/alsa-utils/Makefile View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-utils
PKG_VERSION:=1.1.9
PKG_VERSION:=1.2.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
http://distfiles.gentoo.org/distfiles/
PKG_HASH:=5ddf2cbddb4bd1a4a2a6492a09c25898b08c3ad64893c3655be14194cf0a213a
PKG_HASH:=44807bd578c5f6df6e91a11b8d37e546424a5a1ea8d8e659ee359fe01730e4f3
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_LICENSE:=GPL-2.0-or-later
@ -50,7 +50,7 @@ define Package/alsa-utils-tests
URL:=https://www.alsa-project.org/
endef
CONFIGURE_ARGS+= \
CONFIGURE_ARGS += \
--disable-rpath \
--disable-alsatest \
--disable-bat \
@ -58,6 +58,11 @@ CONFIGURE_ARGS+= \
--disable-rst2man \
--with-curses=ncursesw
CONFIGURE_VARS += \
ac_cv_header_samplerate_h=no
TARGET_LDFLAGS += -latopology
define Package/alsa-utils/install
$(INSTALL_DIR) $(1)/usr/{s,}bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amixer $(1)/usr/bin/


+ 0
- 23
sound/alsa-utils/patches/100-uClibc-compat.patch View File

@ -1,23 +0,0 @@
--- a/alsamixer/volume_mapping.c
+++ b/alsamixer/volume_mapping.c
@@ -108,9 +108,9 @@ static double get_normalized_volume(snd_
if (use_linear_dB_scale(min, max))
return (value - min) / (double)(max - min);
- normalized = exp10((value - max) / 6000.0);
+ normalized = pow(10, (value - max) / 6000.0);
if (min != SND_CTL_TLV_DB_GAIN_MUTE) {
- min_norm = exp10((min - max) / 6000.0);
+ min_norm = pow(10, (min - max) / 6000.0);
normalized = (normalized - min_norm) / (1 - min_norm);
}
@@ -143,7 +143,7 @@ static int set_normalized_volume(snd_mix
}
if (min != SND_CTL_TLV_DB_GAIN_MUTE) {
- min_norm = exp10((min - max) / 6000.0);
+ min_norm = pow(10, (min - max) / 6000.0);
volume = volume * (1 - min_norm) + min_norm;
}
value = lrint_dir(6000.0 * log10(volume), dir) + max;

+ 0
- 28
sound/alsa-utils/patches/101-disable-libsamplerate.patch View File

@ -1,28 +0,0 @@
--- a/alsaloop/Makefile.am
+++ b/alsaloop/Makefile.am
@@ -1,9 +1,9 @@
AM_CPPFLAGS = -I$(top_srcdir)/include
LDADD = -lm
AM_CFLAGS = -D_GNU_SOURCE
-if HAVE_SAMPLERATE
-LDADD += -lsamplerate
-endif
+# if HAVE_SAMPLERATE
+# LDADD += -lsamplerate
+# endif
# LDFLAGS = -static
# CFLAGS += -g -Wall
--- a/configure.ac
+++ b/configure.ac
@@ -38,8 +38,8 @@ AC_CHECK_HEADERS([alsa/use-case.h], [have_ucm="yes"], [have_ucm="no"],
[#include <alsa/asoundlib.h>])
AC_CHECK_HEADERS([alsa/topology.h], [have_topology="yes"], [have_topology="no"],
[#include <alsa/asoundlib.h>])
-AC_CHECK_HEADERS([samplerate.h], [have_samplerate="yes"], [have_samplerate="no"],
- [#include <samplerate.h>])
+dnl AC_CHECK_HEADERS([samplerate.h], [have_samplerate="no"], [have_samplerate="no"],
+dnl [#include <samplerate.h>])
AC_CHECK_LIB([asound], [snd_seq_client_info_get_card], [HAVE_SEQ_CLIENT_INFO_GET_CARD="yes"])
if test "$HAVE_SEQ_CLIENT_INFO_GET_CARD" = "yes" ; then

Loading…
Cancel
Save