Browse Source

setools: fix compilation with python 3.9

Don't warn on deprecated declarations.

Rename warning patch. It's specific to foritfy-headers.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
21f19a4cab
3 changed files with 11 additions and 1 deletions
  1. +1
    -1
      utils/setools/Makefile
  2. +0
    -0
      utils/setools/patches/010-no-format.patch
  3. +10
    -0
      utils/setools/patches/020-no-deprecated.patch

+ 1
- 1
utils/setools/Makefile View File

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=setools
PKG_VERSION:=4.3.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://github.com/SELinuxProject/setools/releases/download/4.3.0


utils/setools/patches/010-fewer-warnings.patch → utils/setools/patches/010-no-format.patch View File


+ 10
- 0
utils/setools/patches/020-no-deprecated.patch View File

@ -0,0 +1,10 @@
--- a/setup.py
+++ b/setup.py
@@ -126,6 +126,7 @@ ext_py_mods = [Extension('setools.policyrep', ['setools/policyrep.pyx'],
'-Wno-unreachable-code',
'-Wno-implicit-fallthrough',
'-Wno-cast-function-type',
+ '-Wno-deprecated-declarations',
'-fno-exceptions'])]
installed_data = [('share/man/man1', glob.glob("man/*.1"))]

Loading…
Cancel
Save