|
|
@ -1,6 +1,6 @@ |
|
|
|
--- a/configure.ac
|
|
|
|
+++ b/configure.ac
|
|
|
|
@@ -721,6 +721,11 @@ AC_CACHE_CHECK([whether clock_boottime a
|
|
|
|
@@ -712,6 +712,11 @@ AC_CACHE_CHECK([whether clock_boottime a
|
|
|
|
] |
|
|
|
) |
|
|
|
|
|
|
@ -12,7 +12,7 @@ |
|
|
|
|
|
|
|
# |
|
|
|
# Checks for typedefs, structures, and compiler characteristics. |
|
|
|
@@ -6392,6 +6397,7 @@ plugin_ipc="no"
|
|
|
|
@@ -6394,6 +6399,7 @@ plugin_ipc="no"
|
|
|
|
plugin_ipmi="no" |
|
|
|
plugin_ipvs="no" |
|
|
|
plugin_irq="no" |
|
|
@ -20,7 +20,7 @@ |
|
|
|
plugin_load="no" |
|
|
|
plugin_log_logstash="no" |
|
|
|
plugin_mcelog="no" |
|
|
|
@@ -6826,6 +6832,7 @@ AC_PLUGIN([ipmi], [$plugi
|
|
|
|
@@ -6828,6 +6834,7 @@ AC_PLUGIN([ipmi], [$plugi
|
|
|
|
AC_PLUGIN([iptables], [$with_libiptc], [IPTables rule counters]) |
|
|
|
AC_PLUGIN([ipvs], [$plugin_ipvs], [IPVS connection statistics]) |
|
|
|
AC_PLUGIN([irq], [$plugin_irq], [IRQ statistics]) |
|
|
@ -28,7 +28,7 @@ |
|
|
|
AC_PLUGIN([java], [$with_java], [Embed the Java Virtual Machine]) |
|
|
|
AC_PLUGIN([load], [$plugin_load], [System load]) |
|
|
|
AC_PLUGIN([log_logstash], [$plugin_log_logstash], [Logstash json_event compatible logging]) |
|
|
|
@@ -7193,6 +7200,7 @@ AC_MSG_RESULT([ libyajl . . . . . . .
|
|
|
|
@@ -7197,6 +7204,7 @@ AC_MSG_RESULT([ libyajl . . . . . . .
|
|
|
|
AC_MSG_RESULT([ oracle . . . . . . . $with_oracle]) |
|
|
|
AC_MSG_RESULT([ protobuf-c . . . . . $have_protoc_c]) |
|
|
|
AC_MSG_RESULT([ protoc 3 . . . . . . $have_protoc3]) |
|
|
@ -36,7 +36,7 @@ |
|
|
|
AC_MSG_RESULT() |
|
|
|
AC_MSG_RESULT([ Features:]) |
|
|
|
AC_MSG_RESULT([ daemon mode . . . . . $enable_daemon]) |
|
|
|
@@ -7253,6 +7261,7 @@ AC_MSG_RESULT([ ipmi . . . . . . . .
|
|
|
|
@@ -7257,6 +7265,7 @@ AC_MSG_RESULT([ ipmi . . . . . . . .
|
|
|
|
AC_MSG_RESULT([ iptables . . . . . . $enable_iptables]) |
|
|
|
AC_MSG_RESULT([ ipvs . . . . . . . . $enable_ipvs]) |
|
|
|
AC_MSG_RESULT([ irq . . . . . . . . . $enable_irq]) |
|
|
@ -252,7 +252,7 @@ |
|
|
|
+}
|
|
|
|
--- a/src/types.db
|
|
|
|
+++ b/src/types.db
|
|
|
|
@@ -240,6 +240,7 @@ voltage_threshold value:GAUGE:U:U,
|
|
|
|
@@ -240,6 +240,7 @@ snr value:GAUGE:0:U
|
|
|
|
spam_check value:GAUGE:0:U |
|
|
|
spam_score value:GAUGE:U:U |
|
|
|
spl value:GAUGE:U:U |
|
|
@ -262,7 +262,7 @@ |
|
|
|
tcp_connections value:GAUGE:0:4294967295 |
|
|
|
--- a/Makefile.am
|
|
|
|
+++ b/Makefile.am
|
|
|
|
@@ -1149,6 +1149,14 @@ irq_la_LDFLAGS = $(PLUGIN_LDFLAGS)
|
|
|
|
@@ -1150,6 +1150,14 @@ irq_la_LDFLAGS = $(PLUGIN_LDFLAGS)
|
|
|
|
irq_la_LIBADD = libignorelist.la |
|
|
|
endif |
|
|
|
|
|
|
|