Browse Source

i2pd: backport upstream fix for i386

Fixes compilation.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
1eff28553e
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 33 additions and 3 deletions
  1. +1
    -1
      net/i2pd/Makefile
  2. +0
    -2
      net/i2pd/patches/010-config.patch
  3. +32
    -0
      net/i2pd/patches/020-x86.patch

+ 1
- 1
net/i2pd/Makefile View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=i2pd
PKG_VERSION:=2.35.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/PurpleI2P/i2pd/tar.gz/$(PKG_VERSION)?


+ 0
- 2
net/i2pd/patches/010-config.patch View File

@ -1,5 +1,3 @@
diff --git a/contrib/i2pd.conf b/contrib/i2pd.conf
index 5ef39bc9..8d5034eb 100644
--- a/contrib/i2pd.conf
+++ b/contrib/i2pd.conf
@@ -8,12 +8,12 @@


+ 32
- 0
net/i2pd/patches/020-x86.patch View File

@ -0,0 +1,32 @@
From ca3b8191510c1006d031d02c50edcf6b4f6a6e8f Mon Sep 17 00:00:00 2001
From: R4SAS <r4sas@i2pmail.org>
Date: Thu, 10 Dec 2020 18:32:41 +0300
Subject: [PATCH] [avx] check ig c++ target supports AVX
Signed-off-by: R4SAS <r4sas@i2pmail.org>
---
libi2pd/Crypto.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/libi2pd/Crypto.cpp
+++ b/libi2pd/Crypto.cpp
@@ -638,7 +638,7 @@ namespace crypto
{
uint64_t buf[256];
uint64_t hash[12]; // 96 bytes
-#if defined(__x86_64__) || defined(__i386__)
+#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
if(i2p::cpu::avx)
{
__asm__
--- a/libi2pd/Identity.cpp
+++ b/libi2pd/Identity.cpp
@@ -828,7 +828,7 @@ namespace data
XORMetric operator^(const IdentHash& key1, const IdentHash& key2)
{
XORMetric m;
-#if defined(__x86_64__) || defined(__i386__)
+#if (defined(__x86_64__) || defined(__i386__)) && defined(__AVX__) // not all X86 targets supports AVX (like old Pentium, see #1600)
if(i2p::cpu::avx)
{
__asm__

Loading…
Cancel
Save