Browse Source

ola: fix build (linking issue TCPSocket::ReadDescriptor() const)

Reported buildbot issue is:
/store/buildbot/slave/ar71xx/build/build_dir/target-mips_34kc_musl-1.1.11/ola-0.9.7/plugins/openpixelcontrol/.libs/libolaopenpixelcontrol.so: undefined reference to `ola::network::TCPSocket::ReadDescriptor() const'
collect2: error: ld returned 1 exit status

There's also a discussion (attempt) to fix this on the buildroot project:
  https://patchwork.ozlabs.org/patch/503884/

This bug has been reported (from the buildroot project), here:
  https://github.com/OpenLightingProject/ola/issues/880

This commit introduced the issue:
  bfc1d99055
specifically the `-fvisibility-inlines-hidden` switch.

So, until, the upstream project (ola) fixes this, this fix
looks like the quickest/simplest workaround to have this package build.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 9 years ago
parent
commit
1c74804bc5
1 changed files with 13 additions and 0 deletions
  1. +13
    -0
      net/ola/patches/002-remove-visibility-inlines-hidden-flag.patch

+ 13
- 0
net/ola/patches/002-remove-visibility-inlines-hidden-flag.patch View File

@ -0,0 +1,13 @@
diff --git a/Makefile.am b/Makefile.am
index 22647be..7dcf0de 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,7 +32,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = --enable-python-libs
COMMON_CXXFLAGS_ONLY_WARNINGS = \
-I$(top_srcdir)/include \
-I$(top_builddir)/include \
- -Wall -Wformat -W -fvisibility-inlines-hidden \
+ -Wall -Wformat -W \
$(libprotobuf_CFLAGS)
COMMON_CXXFLAGS = $(COMMON_CXXFLAGS_ONLY_WARNINGS)

Loading…
Cancel
Save