Browse Source

knot: update to 2.2.1

Signed-off-by: Daniel Salzman <daniel.salzman@nic.cz>
lilik-openwrt-22.03
Daniel Salzman 8 years ago
parent
commit
1a99ae0356
2 changed files with 2 additions and 39 deletions
  1. +2
    -2
      net/knot/Makefile
  2. +0
    -37
      net/knot/patches/04_hostname.patch

+ 2
- 2
net/knot/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=knot
PKG_VERSION:=2.2.0
PKG_VERSION:=2.2.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://secure.nic.cz/files/knot-dns/
PKG_MD5SUM:=ac00a189038fd692c53b2e8c1837c5cb
PKG_MD5SUM:=d573ecadedf4f15ec1f02671443520cb
PKG_MAINTAINER:=Daniel Salzman <daniel.salzman@nic.cz>
PKG_LICENSE:=GPL-3.0 LGPL-2.0 0BSD MIT OLDAP-2.8


+ 0
- 37
net/knot/patches/04_hostname.patch View File

@ -1,37 +0,0 @@
diff --git a/src/knot/conf/base.c b/src/knot/conf/base.c
index 9a0a655..e4721ad 100644
--- a/src/knot/conf/base.c
+++ b/src/knot/conf/base.c
@@ -101,6 +101,10 @@ void conf_refresh_hostname(
free(conf->hostname);
conf->hostname = sockaddr_hostname();
+ if (conf->hostname == NULL) {
+ // Empty hostname fallback, NULL cannot be passed to strlen!
+ conf->hostname = strdup("");
+ }
}
static void init_cache(
@@ -206,7 +210,7 @@ int conf_new(
// Cache the current hostname.
if (!(flags & CONF_FNOHOSTNAME)) {
- out->hostname = sockaddr_hostname();
+ conf_refresh_hostname(out);
}
// Initialize cached values.
diff --git a/src/knot/modules/dnstap.c b/src/knot/modules/dnstap.c
index 890663d..b60c1ca 100644
--- a/src/knot/modules/dnstap.c
+++ b/src/knot/modules/dnstap.c
@@ -241,7 +241,7 @@ int dnstap_load(struct query_plan *plan, struct query_module *self,
} else {
ctx->identity = sockaddr_hostname();
}
- ctx->identity_len = strlen(ctx->identity);
+ ctx->identity_len = (ctx->identity != NULL) ? strlen(ctx->identity) : 0;
// Set version.
val = conf_mod_get(self->config, MOD_VERSION, self->id);

Loading…
Cancel
Save