Browse Source

Merge pull request #238 from ejonny/reduce-dependencies-of-ibr-packages

Reduce dependencies of ibr packages
lilik-openwrt-22.03
sbyx 10 years ago
parent
commit
1a844d072b
6 changed files with 203 additions and 2 deletions
  1. +2
    -1
      libs/ibrdtn/Makefile
  2. +33
    -0
      libs/ibrdtn/patches/100-add_configure_options.patch
  3. +3
    -0
      net/ibrdtn-tools/Makefile
  4. +89
    -0
      net/ibrdtn-tools/patches/100-add_configure_options.patch
  5. +1
    -1
      net/ibrdtnd/Makefile
  6. +75
    -0
      net/ibrdtnd/patches/100-add_configure_options.patch

+ 2
- 1
libs/ibrdtn/Makefile View File

@ -34,7 +34,8 @@ define Package/ibrdtn/description
endef
CONFIGURE_ARGS += \
--with-compression
--with-compression \
--without-glib
define Build/InstallDev
$(INSTALL_DIR) $(1)


+ 33
- 0
libs/ibrdtn/patches/100-add_configure_options.patch View File

@ -0,0 +1,33 @@
--- a/configure.ac
+++ b/configure.ac
@@ -159,12 +159,21 @@ AS_IF([test "x$enable_android" = "xyes"], [
dnl -----------------------------------------------
dnl check for glib support
dnl -----------------------------------------------
- PKG_CHECK_MODULES([GLIB], [glib-2.0], [
- AC_SUBST(GLIB_CFLAGS)
- AC_SUBST(GLIB_LIBS)
- AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
- REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
- ], [
+ AC_ARG_WITH([glib], [AS_HELP_STRING([--without-glib], [Disable linking to glib-2.0 library])], [with_glib=no], [with_glib=yes])
+ AS_IF([test "x$with_glib" != xno],
+ [
+ PKG_CHECK_MODULES([GLIB], [glib-2.0], [
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+ AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
+ REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
+ ], [
+ with_glib=no
+ ])
+ ], [])
+
+ AS_IF([test "x$with_glib" = xno],
+ [
AS_IF([test "x$has_endian_h" = "xyes"],[
AC_MSG_NOTICE([use endian.h for endianess conversion])
],[
--
1.9.1

+ 3
- 0
net/ibrdtn-tools/Makefile View File

@ -33,6 +33,9 @@ define Package/ibrdtn-tools/description
and a tools to ping a DTN node (dtnping).
endef
CONFIGURE_ARGS += \
--without-libdaemon
define Package/ibrdtn-tools/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtnping $(1)/usr/bin/dtnping


+ 89
- 0
net/ibrdtn-tools/patches/100-add_configure_options.patch View File

@ -0,0 +1,89 @@
--- a/configure.ac
+++ b/configure.ac
@@ -67,34 +67,57 @@ AC_TYPE_UINT8_T
AC_FUNC_MALLOC
AC_CHECK_FUNCS([memset])
-PKG_CHECK_MODULES(DAEMON, libdaemon >= 0.12, [
- AC_SUBST(DAEMON_CFLAGS)
- AC_SUBST(DAEMON_LIBS)
- AC_DEFINE(HAVE_LIBDAEMON, [1], ["daemon library is available"])
- AC_CHECK_LIB(daemon, daemon_reset_sigs, [
- AC_DEFINE(HAVE_DAEMON_RESET_SIGS, [1], ["daemon library has daemon_reset_sigs() and daemon_unblock_sigs() functions"])
- ])
-], [
- AC_MSG_WARN([daemon library not found, daemonize features disabled])
-])
+AC_ARG_WITH([libdaemon],
+ AS_HELP_STRING([--without-libdaemon], [Build without daemonize support]),
+ [
+ AC_MSG_NOTICE([daemonize support disabled])
+ ], [
+ PKG_CHECK_MODULES(DAEMON, libdaemon >= 0.12, [
+ AC_SUBST(DAEMON_CFLAGS)
+ AC_SUBST(DAEMON_LIBS)
+ AC_DEFINE(HAVE_LIBDAEMON, [1], ["daemon library is available"])
+ AC_CHECK_LIB(daemon, daemon_reset_sigs, [
+ AC_DEFINE(HAVE_DAEMON_RESET_SIGS, [1], ["daemon library has daemon_reset_sigs() and daemon_unblock_sigs() functions"])
+ ])
+ ], [
+ AC_MSG_WARN([daemon library not found, daemonize features disabled])
+ ])
+ ]
+)
-PKG_CHECK_MODULES(ARCHIVE, libarchive >= 3.0, [
- AC_SUBST(ARCHIVE_CFLAGS)
- AC_SUBST(ARCHIVE_LIBS)
- AC_DEFINE(HAVE_LIBARCHIVE, [1], ["libarchive is available"])
- has_libarchive="yes"
-], [
- AC_MSG_WARN([libarchive not found, dtninbox and dtnoutbox will not be compiled])
-])
+AC_ARG_WITH([libarchive],
+ AS_HELP_STRING([--without-libarchive], [Build without archive support]),
+ [
+ has_libarchive="no"
+ AC_MSG_NOTICE([archive support disabled, dtninbox and dtnoutbox will not be compiled])
+ ], [
+ PKG_CHECK_MODULES(ARCHIVE, libarchive >= 3.0, [
+ AC_SUBST(ARCHIVE_CFLAGS)
+ AC_SUBST(ARCHIVE_LIBS)
+ AC_DEFINE(HAVE_LIBARCHIVE, [1], ["libarchive is available"])
+ has_libarchive="yes"
+ ], [
+ AC_MSG_WARN([libarchive not found, dtninbox and dtnoutbox will not be compiled])
+ ])
+ ]
+)
-PKG_CHECK_MODULES(OPENSSL, openssl, [
- AC_SUBST(OPENSSL_CFLAGS)
- AC_SUBST(OPENSSL_LIBS)
- AC_DEFINE(HAVE_OPENSSL, [1], ["openssl available"])
- has_openssl="yes"
-], [
- AC_MSG_WARN([openssl not found, dtninbox and dtnoutbox will not be compiled])
-])
+AC_ARG_WITH([openssl],
+ AS_HELP_STRING([--without-openssl], [Build without openssl support]),
+ [
+ has_openssl="no"
+ AC_MSG_NOTICE([openssl support disabled, dtninbox and dtnoutbox will not be compiled])
+ ], [
+ PKG_CHECK_MODULES(OPENSSL, openssl, [
+ AC_SUBST(OPENSSL_CFLAGS)
+ AC_SUBST(OPENSSL_LIBS)
+ AC_DEFINE(HAVE_OPENSSL, [1], ["openssl available"])
+ has_openssl="yes"
+ ], [
+ AC_MSG_WARN([openssl not found, dtninbox and dtnoutbox will not be compiled])
+ ])
+ ]
+)
AC_ARG_WITH([tffs],
AS_HELP_STRING([--with-tffs=PATH], [set the tffs path for fat-image support in dtnoutbox]), [
--
1.9.1

+ 1
- 1
net/ibrdtnd/Makefile View File

@ -37,7 +37,7 @@ define Package/ibrdtnd/description
endef
CONFIGURE_ARGS += \
--with-tls --with-sqlite --with-dht
--with-tls --with-sqlite --with-dht --without-wifip2p --without-vmime
define Package/ibrdtnd/install
$(INSTALL_DIR) $(1)/usr/sbin/


+ 75
- 0
net/ibrdtnd/patches/100-add_configure_options.patch View File

@ -0,0 +1,75 @@
--- a/configure.ac
+++ b/configure.ac
@@ -333,30 +333,46 @@ AS_IF([test "x$enable_android" = "xyes"], [
dnl optional parameter: Wifi-P2P support
dnl -----------------------------------------------
- PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
- with_wifi_p2p="yes"
- AC_SUBST(WIFIP2P_CFLAGS)
- AC_SUBST(WIFIP2P_LIBS)
- AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
- ], [
- with_wifi_p2p="no"
- AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
- ])
+ AC_ARG_WITH([wifip2p],
+ AS_HELP_STRING([--without-wifip2p], [Build without wifip2p support]),
+ [
+ with_wifi_p2p="no"
+ AC_MSG_NOTICE([WIFIP2P support disabled])
+ ], [
+ PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
+ with_wifi_p2p="yes"
+ AC_SUBST(WIFIP2P_CFLAGS)
+ AC_SUBST(WIFIP2P_LIBS)
+ AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
+ ], [
+ with_wifi_p2p="no"
+ AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
+ ])
+ ]
+ )
- dnl -----------------------------------------------
- dnl optional parameter: VMime support
- dnl -----------------------------------------------
-
- PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
- with_vmime="yes"
- AC_SUBST(VMIME_CFLAGS)
- AC_SUBST(VMIME_LIBS)
- AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
- AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
- ], [
- with_vmime="no"
- AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
- ])
+ dnl -----------------------------------------------
+ dnl optional parameter: VMime support
+ dnl -----------------------------------------------
+
+ AC_ARG_WITH([vmime],
+ AS_HELP_STRING([--without-vmime], [Build without vmime support]),
+ [
+ with_vmime="no"
+ AC_MSG_NOTICE([VMIME support disabled])
+ ], [
+ PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
+ with_vmime="yes"
+ AC_SUBST(VMIME_CFLAGS)
+ AC_SUBST(VMIME_LIBS)
+ AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
+ AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
+ ], [
+ with_vmime="no"
+ AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
+ ])
+ ]
+ )
dnl -----------------------------------------------
dnl check for regex capabilities
--
1.9.1

Loading…
Cancel
Save