Browse Source

openzwave: fix gcc7 compile and remove bad patch

Patch 903-no-examples.patch removes MinOZW binary. This is wrong since
install section of openzwave is still using it. We can either remove the
patch or remove install section for openzwave. It seems people are using
this binary so we remove the patch.

After removing the patch the following issue appears with gcc7:
cc1plus: error: -Wformat-security ignored without -Wformat

This is resolved by adding the following to Makefile
TARGET_CPPFLAGS+=-Wno-format -Wno-format-security

Signed-off-by: Marko Ratkaj <marko.ratkaj@sartura.hr>
lilik-openwrt-22.03
Marko Ratkaj 6 years ago
parent
commit
1a4d9b7aba
2 changed files with 2 additions and 18 deletions
  1. +2
    -0
      utils/openzwave/Makefile
  2. +0
    -18
      utils/openzwave/patches/903-no-examples.patch

+ 2
- 0
utils/openzwave/Makefile View File

@ -53,6 +53,8 @@ $(call Package/openzwave/default)
TITLE:=Open-ZWave Device Configs
endef
TARGET_CPPFLAGS+=-Wno-format -Wno-format-security
MAKE_FLAGS += \
LD="$(TARGET_CROSS)g++" \
LIBDIR="$(PKG_BUILD_DIR)" \


+ 0
- 18
utils/openzwave/patches/903-no-examples.patch View File

@ -1,18 +0,0 @@
--- a/Makefile
+++ b/Makefile
@@ -18,15 +18,12 @@
all:
CPPFLAGS=$(CPPFLAGS) $(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS)
- CPPFLAGS=$(CPPFLAGS) $(MAKE) -C $(top_srcdir)/cpp/examples/MinOZW/ -$(MAKEFLAGS)
install:
$(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS) $(MAKECMDGOALS)
- $(MAKE) -C $(top_srcdir)/cpp/examples/MinOZW/ -$(MAKEFLAGS) $(MAKECMDGOALS)
clean:
$(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS) $(MAKECMDGOALS)
- $(MAKE) -C $(top_srcdir)/cpp/examples/MinOZW/ -$(MAKEFLAGS) $(MAKECMDGOALS)
cpp/src/vers.cpp:
CPPFLAGS=$(CPPFLAGS) $(MAKE) -C $(top_srcdir)/cpp/build/ -$(MAKEFLAGS) cpp/src/vers.cpp

Loading…
Cancel
Save