Browse Source

Merge pull request #1891 from wifidog/wifidog-1.3.0

wifidog: Bump to 1.3.0
lilik-openwrt-22.03
Steven Barth 9 years ago
parent
commit
197a2c210f
2 changed files with 3 additions and 50 deletions
  1. +3
    -3
      net/wifidog/Makefile
  2. +0
    -47
      net/wifidog/patches/100-musl-compat.patch

+ 3
- 3
net/wifidog/Makefile View File

@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wifidog
PKG_VERSION:=1.2.1
PKG_RELEASE=2
PKG_VERSION:=1.3.0
PKG_RELEASE=1
PKG_LICENSE:=GPL-2.0
@ -22,7 +22,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/wifidog/wifidog-gateway.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=1.2.1
PKG_SOURCE_VERSION:=1.3.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_FIXUP:=autoreconf


+ 0
- 47
net/wifidog/patches/100-musl-compat.patch View File

@ -1,47 +0,0 @@
--- a/libhttpd/protocol.c
+++ b/libhttpd/protocol.c
@@ -28,6 +28,7 @@
#if defined(_WIN32)
#else
+#include <fcntl.h>
#include <unistd.h>
#include <sys/file.h>
#endif
--- a/src/firewall.c
+++ b/src/firewall.c
@@ -35,7 +35,6 @@
#include <pthread.h>
#include <sys/wait.h>
#include <sys/types.h>
-#include <sys/unistd.h>
#include <string.h>
--- a/src/client_list.c
+++ b/src/client_list.c
@@ -31,9 +31,9 @@
#include <syslog.h>
#include <errno.h>
#include <pthread.h>
+#include <unistd.h>
#include <sys/wait.h>
#include <sys/types.h>
-#include <sys/unistd.h>
#include <string.h>
--- a/src/util.c
+++ b/src/util.c
@@ -33,10 +33,10 @@
#include <syslog.h>
#include <errno.h>
#include <pthread.h>
+#include <unistd.h>
#include <sys/wait.h>
#include <sys/types.h>
#include <sys/time.h>
-#include <sys/unistd.h>
#include <netinet/in.h>
#include <sys/ioctl.h>
#include <arpa/inet.h>

Loading…
Cancel
Save