|
|
@ -5,36 +5,36 @@ |
|
|
|
ARG_ENABL_SET([gcrypt], [enables the libgcrypt plugin.]) |
|
|
|
ARG_DISBL_SET([gmp], [disable GNU MP (libgmp) based crypto implementation plugin.]) |
|
|
|
+ARG_DISBL_SET([gmpdh], [disable GNU MP (libgmp) based static-linked crypto DH minimal implementation plugin.])
|
|
|
|
ARG_DISBL_SET([curve25519], [disable Curve25519 Diffie-Hellman plugin.]) |
|
|
|
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.]) |
|
|
|
ARG_ENABL_SET([md4], [enable MD4 software implementation plugin.]) |
|
|
|
ARG_DISBL_SET([md5], [disable MD5 software implementation plugin.]) |
|
|
|
@@ -1347,6 +1348,7 @@ ADD_PLUGIN([gcrypt], [s ch
|
|
|
|
@@ -1362,6 +1363,7 @@ ADD_PLUGIN([gcrypt], [s ch
|
|
|
|
ADD_PLUGIN([af-alg], [s charon scepclient pki scripts medsrv attest nm cmd aikgen]) |
|
|
|
ADD_PLUGIN([fips-prf], [s charon nm cmd]) |
|
|
|
ADD_PLUGIN([gmp], [s charon scepclient pki scripts manager medsrv attest nm cmd aikgen]) |
|
|
|
+ADD_PLUGIN([gmpdh], [s charon scepclient pki scripts manager medsrv attest nm cmd aikgen])
|
|
|
|
ADD_PLUGIN([curve25519], [s charon scripts nm cmd]) |
|
|
|
ADD_PLUGIN([agent], [s charon nm cmd]) |
|
|
|
ADD_PLUGIN([keychain], [s charon cmd]) |
|
|
|
ADD_PLUGIN([chapoly], [s charon scripts nm cmd]) |
|
|
|
@@ -1480,6 +1482,7 @@ AM_CONDITIONAL(USE_SHA2, test x$sha2 = x
|
|
|
|
AM_CONDITIONAL(USE_SHA3, test x$sha3 = xtrue) |
|
|
|
@@ -1498,6 +1500,7 @@ AM_CONDITIONAL(USE_SHA3, test x$sha3 = x
|
|
|
|
AM_CONDITIONAL(USE_MGF1, test x$mgf1 = xtrue) |
|
|
|
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue) |
|
|
|
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue) |
|
|
|
+AM_CONDITIONAL(USE_GMPDH, test x$gmpdh = xtrue)
|
|
|
|
AM_CONDITIONAL(USE_CURVE25519, test x$curve25519 = xtrue) |
|
|
|
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue) |
|
|
|
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue) |
|
|
|
AM_CONDITIONAL(USE_RANDOM, test x$random = xtrue) |
|
|
|
@@ -1733,6 +1736,7 @@ AC_CONFIG_FILES([
|
|
|
|
src/libstrongswan/plugins/sha3/Makefile |
|
|
|
@@ -1756,6 +1759,7 @@ AC_CONFIG_FILES([
|
|
|
|
src/libstrongswan/plugins/mgf1/Makefile |
|
|
|
src/libstrongswan/plugins/fips_prf/Makefile |
|
|
|
src/libstrongswan/plugins/gmp/Makefile |
|
|
|
+ src/libstrongswan/plugins/gmpdh/Makefile
|
|
|
|
src/libstrongswan/plugins/curve25519/Makefile |
|
|
|
src/libstrongswan/plugins/rdrand/Makefile |
|
|
|
src/libstrongswan/plugins/aesni/Makefile |
|
|
|
src/libstrongswan/plugins/random/Makefile |
|
|
|
--- a/src/libstrongswan/Makefile.am
|
|
|
|
+++ b/src/libstrongswan/Makefile.am
|
|
|
|
@@ -307,6 +307,13 @@ if MONOLITHIC
|
|
|
|
@@ -313,6 +313,13 @@ if MONOLITHIC
|
|
|
|
endif |
|
|
|
endif |
|
|
|
|
|
|
@ -45,8 +45,8 @@ |
|
|
|
+endif
|
|
|
|
+endif
|
|
|
|
+
|
|
|
|
if USE_RDRAND |
|
|
|
SUBDIRS += plugins/rdrand |
|
|
|
if USE_CURVE25519 |
|
|
|
SUBDIRS += plugins/curve25519 |
|
|
|
if MONOLITHIC |
|
|
|
--- /dev/null
|
|
|
|
+++ b/src/libstrongswan/plugins/gmpdh/Makefile.am
|
|
|
|