Browse Source

python3: bump to version 3.9.4

For some reason Python3 jumped from 3.9.2 to 3.9.4 in about a week.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 4 years ago
committed by Hannu Nyman
parent
commit
156e2e354e
6 changed files with 11 additions and 11 deletions
  1. +1
    -1
      lang/python/python3-version.mk
  2. +1
    -1
      lang/python/python3/Makefile
  3. +2
    -2
      lang/python/python3/patches/003-do-not-run-distutils-tests.patch
  4. +1
    -1
      lang/python/python3/patches/014-remove-platform-so-suffix.patch
  5. +5
    -5
      lang/python/python3/patches/016-adjust-config-paths.patch
  6. +1
    -1
      lang/python/python3/patches/025-choose-python-config-version.patch

+ 1
- 1
lang/python/python3-version.mk View File

@ -8,7 +8,7 @@
# Note: keep in sync with setuptools & pip # Note: keep in sync with setuptools & pip
PYTHON3_VERSION_MAJOR:=3 PYTHON3_VERSION_MAJOR:=3
PYTHON3_VERSION_MINOR:=9 PYTHON3_VERSION_MINOR:=9
PYTHON3_VERSION_MICRO:=2
PYTHON3_VERSION_MICRO:=4
PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR) PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)


+ 1
- 1
lang/python/python3/Makefile View File

@ -16,7 +16,7 @@ PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION) PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
PKG_HASH:=3c2034c54f811448f516668dce09d24008a0716c3a794dd8639b5388cbde247d
PKG_HASH:=4b0e6644a76f8df864ae24ac500a51bbf68bd098f6a173e27d3b61cdca9aa134
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com> PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=Python/2.0 PKG_LICENSE:=Python/2.0


+ 2
- 2
lang/python/python3/patches/003-do-not-run-distutils-tests.patch View File

@ -1,6 +1,6 @@
--- a/Makefile.pre.in --- a/Makefile.pre.in
+++ b/Makefile.pre.in +++ b/Makefile.pre.in
@@ -1525,6 +1525,7 @@ libinstall: build_all $(srcdir)/Modules/
@@ -1526,6 +1526,7 @@ libinstall: build_all $(srcdir)/Modules/
$(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \ $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
$(DESTDIR)$(LIBDEST); \ $(DESTDIR)$(LIBDEST); \
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
@ -8,7 +8,7 @@
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \ if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \ $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
$(DESTDIR)$(LIBDEST)/distutils/tests ; \ $(DESTDIR)$(LIBDEST)/distutils/tests ; \
@@ -1560,6 +1561,7 @@ libinstall: build_all $(srcdir)/Modules/
@@ -1561,6 +1562,7 @@ libinstall: build_all $(srcdir)/Modules/
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt


+ 1
- 1
lang/python/python3/patches/014-remove-platform-so-suffix.patch View File

@ -11,7 +11,7 @@
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -4770,7 +4770,7 @@ AC_SUBST(SOABI)
@@ -4777,7 +4777,7 @@ AC_SUBST(SOABI)
AC_MSG_CHECKING(ABIFLAGS) AC_MSG_CHECKING(ABIFLAGS)
AC_MSG_RESULT($ABIFLAGS) AC_MSG_RESULT($ABIFLAGS)
AC_MSG_CHECKING(SOABI) AC_MSG_CHECKING(SOABI)


+ 5
- 5
lang/python/python3/patches/016-adjust-config-paths.patch View File

@ -20,7 +20,7 @@
abi=sys.abiflags, abi=sys.abiflags,
--- a/Makefile.pre.in --- a/Makefile.pre.in
+++ b/Makefile.pre.in +++ b/Makefile.pre.in
@@ -1534,7 +1534,7 @@ libinstall: build_all $(srcdir)/Modules/
@@ -1535,7 +1535,7 @@ libinstall: build_all $(srcdir)/Modules/
esac; \ esac; \
done; \ done; \
done done
@ -29,7 +29,7 @@
$(DESTDIR)$(LIBDEST); \ $(DESTDIR)$(LIBDEST); \
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
ifeq (@COMPILE_ALL_TESTS@,yes) ifeq (@COMPILE_ALL_TESTS@,yes)
@@ -1692,7 +1692,7 @@ sharedinstall: sharedmods
@@ -1693,7 +1693,7 @@ sharedinstall: sharedmods
--install-scripts=$(BINDIR) \ --install-scripts=$(BINDIR) \
--install-platlib=$(DESTSHARED) \ --install-platlib=$(DESTSHARED) \
--root=$(DESTDIR)/ --root=$(DESTDIR)/
@ -49,7 +49,7 @@
fi fi
elif test "$cross_compiling" = maybe; then elif test "$cross_compiling" = maybe; then
as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5 as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
@@ -15435,7 +15435,7 @@ fi
@@ -15436,7 +15436,7 @@ fi
@ -60,7 +60,7 @@
LIBPL='$(prefix)'"/${PLATLIBDIR}/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}" LIBPL='$(prefix)'"/${PLATLIBDIR}/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -75,7 +75,7 @@ if test "$cross_compiling" = yes; then
@@ -82,7 +82,7 @@ if test "$cross_compiling" = yes; then
AC_MSG_ERROR([python$PACKAGE_VERSION interpreter not found]) AC_MSG_ERROR([python$PACKAGE_VERSION interpreter not found])
fi fi
AC_MSG_RESULT($interp) AC_MSG_RESULT($interp)
@ -69,7 +69,7 @@
fi fi
elif test "$cross_compiling" = maybe; then elif test "$cross_compiling" = maybe; then
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH]) AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
@@ -4828,7 +4828,7 @@ fi],
@@ -4835,7 +4835,7 @@ fi],
dnl define LIBPL after ABIFLAGS and LDVERSION is defined. dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
AC_SUBST(PY_ENABLE_SHARED) AC_SUBST(PY_ENABLE_SHARED)


+ 1
- 1
lang/python/python3/patches/025-choose-python-config-version.patch View File

@ -1,6 +1,6 @@
--- a/Makefile.pre.in --- a/Makefile.pre.in
+++ b/Makefile.pre.in +++ b/Makefile.pre.in
@@ -1586,7 +1586,7 @@ python-config: $(srcdir)/Misc/python-con
@@ -1587,7 +1587,7 @@ python-config: $(srcdir)/Misc/python-con
@ # On Darwin, always use the python version of the script, the shell @ # On Darwin, always use the python version of the script, the shell
@ # version doesn't use the compiler customizations that are provided @ # version doesn't use the compiler customizations that are provided
@ # in python (_osx_support.py). @ # in python (_osx_support.py).


Loading…
Cancel
Save