Browse Source

avahi: Update to 0.7

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 6 years ago
parent
commit
1509fd7123
3 changed files with 17 additions and 73 deletions
  1. +5
    -4
      libs/avahi/Makefile
  2. +12
    -4
      libs/avahi/patches/010-step_back_autotools-no-gettext.patch
  3. +0
    -65
      libs/avahi/patches/011-fix-poll-h-warnings-on-musl.patch

+ 5
- 4
libs/avahi/Makefile View File

@ -8,12 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=avahi
PKG_VERSION:=0.6.32
PKG_RELEASE:=3
PKG_VERSION:=0.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION)
PKG_HASH:=d54991185d514a0aba54ebeb408d7575b60f5818a772e28fa0e18b98bc1db454
PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION) \
https://avahi.org/download
PKG_HASH:=57a99b5dfe7fdae794e3d1ee7a62973a368e91e414bd0dfa5d84434de5b14804
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
PKG_BUILD_DEPENDS:=intltool/host


+ 12
- 4
libs/avahi/patches/010-step_back_autotools-no-gettext.patch View File

@ -1,3 +1,5 @@
diff --git a/Makefile.am b/Makefile.am
index 8234d69..156d4c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,8 +75,7 @@ SUBDIRS = \
@ -10,6 +12,8 @@
DX_INPUT = \
$(srcdir)/avahi-common/address.h \
diff --git a/avahi-python/avahi-discover/Makefile.am b/avahi-python/avahi-discover/Makefile.am
index 5fc4b25..4c39d3d 100644
--- a/avahi-python/avahi-discover/Makefile.am
+++ b/avahi-python/avahi-discover/Makefile.am
@@ -38,7 +38,6 @@ if HAVE_GDBM
@ -28,9 +32,11 @@
avahi_discover_PYTHON += __init__.py
endif
diff --git a/avahi-ui/Makefile.am b/avahi-ui/Makefile.am
index 238d43a..65a147a 100644
--- a/avahi-ui/Makefile.am
+++ b/avahi-ui/Makefile.am
@@ -78,7 +78,6 @@ endif
@@ -80,7 +80,6 @@ endif
bin_PROGRAMS = bssh
desktop_DATA += bssh.desktop bvnc.desktop
@ -38,16 +44,18 @@
bssh_SOURCES = bssh.c
@@ -106,6 +105,4 @@ endif # HAVE_GLIB
@@ -108,6 +107,4 @@ endif # HAVE_GLIB
endif
endif
-@INTLTOOL_DESKTOP_RULE@
-
CLEANFILES = $(desktop_DATA) $(desktop_DATA_in)
diff --git a/configure.ac b/configure.ac
index 6678971..00dac6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ AC_INIT([avahi],[0.6.29],[avahi (at) lis
@@ -23,7 +23,7 @@ AC_INIT([avahi],[0.7],[avahi (at) lists (dot) freedesktop (dot) org])
AC_CONFIG_SRCDIR([avahi-core/server.c])
AC_CONFIG_MACRO_DIR([common])
AC_CONFIG_HEADERS([config.h])
@ -65,7 +73,7 @@
AC_CHECK_PROG([STOW], [stow], [yes], [no])
AS_IF([test "x$STOW" = "xyes" && test -d /usr/local/stow], [
@@ -412,12 +410,6 @@ if test "x$have_kqueue" = "xyes" ; then
@@ -413,12 +411,6 @@ if test "x$have_kqueue" = "xyes" ; then
AC_DEFINE([HAVE_KQUEUE], 1, [Enable BSD kqueue() usage])
fi


+ 0
- 65
libs/avahi/patches/011-fix-poll-h-warnings-on-musl.patch View File

@ -1,65 +0,0 @@
diff --git a/avahi-common/simple-watch.c b/avahi-common/simple-watch.c
index 8df18dd..08d8090 100644
--- a/avahi-common/simple-watch.c
+++ b/avahi-common/simple-watch.c
@@ -21,7 +21,7 @@
#include <config.h>
#endif
-#include <sys/poll.h>
+#include <poll.h>
#include <assert.h>
#include <string.h>
#include <errno.h>
diff --git a/avahi-common/simple-watch.h b/avahi-common/simple-watch.h
index 72c1905..db87122 100644
--- a/avahi-common/simple-watch.h
+++ b/avahi-common/simple-watch.h
@@ -22,7 +22,7 @@
/** \file simple-watch.h Simple poll() based main loop implementation */
-#include <sys/poll.h>
+#include <poll.h>
#include <avahi-common/cdecl.h>
#include <avahi-common/watch.h>
diff --git a/avahi-common/thread-watch.c b/avahi-common/thread-watch.c
index c0cadeb..ecb202b 100644
--- a/avahi-common/thread-watch.c
+++ b/avahi-common/thread-watch.c
@@ -21,7 +21,7 @@
#include <config.h>
#endif
-#include <sys/poll.h>
+#include <poll.h>
#include <assert.h>
#include <string.h>
#include <errno.h>
diff --git a/avahi-common/thread-watch.h b/avahi-common/thread-watch.h
index dec0cf3..1b44ccb 100644
--- a/avahi-common/thread-watch.h
+++ b/avahi-common/thread-watch.h
@@ -22,7 +22,7 @@
/** \file thread-watch.h Threaded poll() based main loop implementation */
-#include <sys/poll.h>
+#include <poll.h>
#include <avahi-common/cdecl.h>
#include <avahi-common/watch.h>
diff --git a/avahi-common/watch.h b/avahi-common/watch.h
index 86e63d3..eea12ec 100644
--- a/avahi-common/watch.h
+++ b/avahi-common/watch.h
@@ -22,7 +22,7 @@
/** \file watch.h Simplistic main loop abstraction */
-#include <sys/poll.h>
+#include <poll.h>
#include <sys/time.h>
#include <avahi-common/cdecl.h>

Loading…
Cancel
Save