- version bump - update license description - add PKG_BUILD_PARALLEL:=1 - remove two cross-compile patches and replace them with the cross-compile patch from buildroot (adds autoreconf to get this going) Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>lilik-openwrt-22.03
@ -1,14 +0,0 @@ | |||
--- a/server/Makefile.in | |||
+++ b/server/Makefile.in | |||
@@ -29,7 +29,10 @@ gen_test_char: $(gen_test_char_OBJECTS) | |||
$(LINK) $(EXTRA_LDFLAGS) $(gen_test_char_OBJECTS) $(EXTRA_LIBS) | |||
test_char.h: gen_test_char | |||
- ./gen_test_char > test_char.h | |||
+ true | |||
+# ./gen_test_char > test_char.h | |||
+# doesn't matter if you run it on the buildhost or on an wl500gd, | |||
+# same output on both, so i just patched in the test_char.h :). | |||
util.lo: test_char.h | |||
@ -0,0 +1,57 @@ | |||
Fix cross-compilation | |||
Fetched httpd-2.4.x-cross_compile.diff from upstream bugtracker: | |||
https://issues.apache.org/bugzilla/show_bug.cgi?id=51257#c6 | |||
which is a bundle of upstream revisions: | |||
http://svn.apache.org/viewvc?view=revision&revision=1327907 | |||
http://svn.apache.org/viewvc?view=revision&revision=1328390 | |||
http://svn.apache.org/viewvc?view=revision&revision=1328714 | |||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> | |||
--- a/server/Makefile.in | |||
+++ b/server/Makefile.in | |||
@@ -24,9 +24,14 @@ TARGETS = delete-exports $(LTLIBRARY_NAM | |||
include $(top_builddir)/build/rules.mk | |||
include $(top_srcdir)/build/library.mk | |||
+ifdef CC_FOR_BUILD | |||
+gen_test_char: gen_test_char.c | |||
+ $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -DCROSS_COMPILE -o $@ $< | |||
+else | |||
gen_test_char_OBJECTS = gen_test_char.lo | |||
gen_test_char: $(gen_test_char_OBJECTS) | |||
$(LINK) $(EXTRA_LDFLAGS) $(gen_test_char_OBJECTS) $(EXTRA_LIBS) | |||
+endif | |||
test_char.h: gen_test_char | |||
./gen_test_char > test_char.h | |||
--- a/configure.in | |||
+++ b/configure.in | |||
@@ -206,6 +206,14 @@ AC_PROG_CPP | |||
dnl Try to get c99 support for variadic macros | |||
ifdef([AC_PROG_CC_C99], [AC_PROG_CC_C99]) | |||
+dnl In case of cross compilation we set CC_FOR_BUILD to cc unless | |||
+dnl we got already CC_FOR_BUILD from environment. | |||
+if test "x${build_alias}" != "x${host_alias}"; then | |||
+ if test "x${CC_FOR_BUILD}" = "x"; then | |||
+ CC_FOR_BUILD=cc | |||
+ fi | |||
+fi | |||
+ | |||
if test "x${cache_file}" = "x/dev/null"; then | |||
# Likewise, ensure that CC and CPP are passed through to the pcre | |||
# configure script iff caching is disabled (the autoconf 2.5x default). | |||
--- a/acinclude.m4 | |||
+++ b/acinclude.m4 | |||
@@ -55,6 +55,8 @@ AC_DEFUN([APACHE_GEN_CONFIG_VARS],[ | |||
APACHE_SUBST(CPPFLAGS) | |||
APACHE_SUBST(CFLAGS) | |||
APACHE_SUBST(CXXFLAGS) | |||
+ APACHE_SUBST(CC_FOR_BUILD) | |||
+ APACHE_SUBST(CFLAGS_FOR_BUILD) | |||
APACHE_SUBST(LTFLAGS) | |||
APACHE_SUBST(LDFLAGS) | |||
APACHE_SUBST(LT_LDFLAGS) |
@ -1,49 +0,0 @@ | |||
Index: httpd-2.4.25/server/test_char.h | |||
=================================================================== | |||
--- /dev/null | |||
+++ httpd-2.4.25/server/test_char.h | |||
@@ -0,0 +1,23 @@ | |||
+/* this file is automatically generated by gen_test_char, do not edit */ | |||
+#define T_ESCAPE_SHELL_CMD (1) | |||
+#define T_ESCAPE_PATH_SEGMENT (2) | |||
+#define T_OS_ESCAPE_PATH (4) | |||
+#define T_HTTP_TOKEN_STOP (8) | |||
+#define T_ESCAPE_LOGITEM (16) | |||
+#define T_ESCAPE_FORENSIC (32) | |||
+ | |||
+static const unsigned char test_char_table[256] = { | |||
+ 32,62,62,62,62,62,62,62,62,62,63,62,62,62,62,62,62,62,62,62, | |||
+ 62,62,62,62,62,62,62,62,62,62,62,62,14,0,23,6,1,38,1,1, | |||
+ 9,9,1,0,8,0,0,10,0,0,0,0,0,0,0,0,0,0,40,15, | |||
+ 15,8,15,15,8,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0, | |||
+ 0,0,0,0,0,0,0,0,0,0,0,15,31,15,7,0,7,0,0,0, | |||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0, | |||
+ 0,0,0,15,39,15,1,62,54,54,54,54,54,54,54,54,54,54,54,54, | |||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54, | |||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54, | |||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54, | |||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54, | |||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54, | |||
+ 54,54,54,54,54,54,54,54,54,54,54,54,54,54,54,54 | |||
+}; | |||
Index: httpd-2.4.25/server/util.c | |||
=================================================================== | |||
--- httpd-2.4.25.orig/server/util.c | |||
+++ httpd-2.4.25/server/util.c | |||
@@ -96,6 +96,16 @@ | |||
#undef APLOG_MODULE_INDEX | |||
#define APLOG_MODULE_INDEX AP_CORE_MODULE_INDEX | |||
+#define T_ESCAPE_SHELL_CMD (0x01) | |||
+#define T_ESCAPE_PATH_SEGMENT (0x02) | |||
+#define T_OS_ESCAPE_PATH (0x04) | |||
+#define T_HTTP_TOKEN_STOP (0x08) | |||
+#define T_ESCAPE_LOGITEM (0x10) | |||
+#define T_ESCAPE_FORENSIC (0x20) | |||
+#define T_ESCAPE_URLENCODED (0x40) | |||
+#define T_HTTP_CTRLS (0x80) | |||
+#define T_VCHAR_OBSTEXT (0x100) | |||
+ | |||
/* | |||
* Examine a field value (such as a media-/content-type) string and return | |||
* it sans any parameters; e.g., strip off any ';charset=foo' and the like. |