Browse Source
Merge pull request #11778 from jefferyto/python-cryptography-2.9
python-cryptography: Update to 2.9, remove setup patch
lilik-openwrt-22.03
Hannu Nyman
5 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
2 additions and
12 deletions
-
lang/python/python-cryptography/Makefile
-
lang/python/python-cryptography/patches/001-disable-setup-requirements.patch
|
|
@ -8,11 +8,11 @@ |
|
|
|
include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=python-cryptography |
|
|
|
PKG_VERSION:=2.8 |
|
|
|
PKG_VERSION:=2.9 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
|
|
|
|
PYPI_NAME:=cryptography |
|
|
|
PKG_HASH:=3cda1f0ed8747339bbdf71b9f38ca74c7b592f24f65cdb3ab3765e4b02871651 |
|
|
|
PKG_HASH:=0cacd3ef5c604b8e5f59bf2582c076c98a37fe206b31430d0cd08138aff0986e |
|
|
|
|
|
|
|
PKG_LICENSE:=Apache-2.0 BSD-3-Clause |
|
|
|
PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD |
|
|
|
|
|
@ -1,10 +0,0 @@ |
|
|
|
--- a/setup.py
|
|
|
|
+++ b/setup.py
|
|
|
|
@@ -243,6 +243,7 @@ class DummyPyTest(test):
|
|
|
|
with open(os.path.join(base_dir, "README.rst")) as f: |
|
|
|
long_description = f.read() |
|
|
|
|
|
|
|
+setup_requirements=[]
|
|
|
|
|
|
|
|
setup( |
|
|
|
name=about["__title__"], |