Browse Source

Merge pull request #2277 from notnyt/feature_cryptodev

cryptodev-linux: bump to 1.8
lilik-openwrt-22.03
Nikos Mavrogiannopoulos 9 years ago
parent
commit
122c477f19
2 changed files with 3 additions and 16 deletions
  1. +3
    -3
      utils/cryptodev-linux/Makefile
  2. +0
    -13
      utils/cryptodev-linux/patches/001-no-get-unused-fd.patch

+ 3
- 3
utils/cryptodev-linux/Makefile View File

@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=cryptodev-linux
PKG_VERSION:=1.7
PKG_RELEASE:=2
PKG_VERSION:=1.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.gna.org/cryptodev-linux/
PKG_MD5SUM:=0b63b3481cf2c90386b35f057481d36b
PKG_MD5SUM:=02644cc4cd02301e0b503a332eb2f0b5
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)


+ 0
- 13
utils/cryptodev-linux/patches/001-no-get-unused-fd.patch View File

@ -1,13 +0,0 @@
Index: cryptodev-linux-1.7/ioctl.c
===================================================================
--- cryptodev-linux-1.7.orig/ioctl.c
+++ cryptodev-linux-1.7/ioctl.c
@@ -546,7 +546,7 @@ static int
clonefd(struct file *filp)
{
int ret;
- ret = get_unused_fd();
+ ret = get_unused_fd_flags(0);
if (ret >= 0) {
get_file(filp);
fd_install(ret, filp);

Loading…
Cancel
Save