Browse Source

aiccu: fix uClibc build after #1389

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
lilik-openwrt-22.03
Jo-Philipp Wich 9 years ago
parent
commit
1208a25e71
3 changed files with 8 additions and 17 deletions
  1. +1
    -1
      ipv6/aiccu/Makefile
  2. +3
    -14
      ipv6/aiccu/patches/300-resolver-uclibc.patch
  3. +4
    -2
      ipv6/aiccu/patches/400-musl-compat.patch

+ 1
- 1
ipv6/aiccu/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=aiccu
PKG_VERSION:=20070115
PKG_RELEASE:=13
PKG_RELEASE:=14
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix


+ 3
- 14
ipv6/aiccu/patches/300-resolver-uclibc.patch View File

@ -5,7 +5,7 @@
int getrrs(const char *label, int rrtype, void gotrec(unsigned int num, int type, const char *record))
{
-#ifdef _LINUX
+#if defined(_LINUX) && defined(__GLIBC__)
+#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
struct __res_state res;
#endif
unsigned char answer[8192];
@ -14,7 +14,7 @@
uint32_t ttl = 0;
-#ifdef _LINUX
+#if defined(_LINUX) && defined(__GLIBC__)
+#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
memset(&res, 0, sizeof(res));
res.options = RES_DEBUG;
res_ninit(&res);
@ -23,18 +23,7 @@
memset(answer, 0, sizeof(answer));
-#ifdef _LINUX
+#if defined(_LINUX) && defined(__GLIBC__)
+#if defined(_LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)
ret = res_nquery(&res, label, C_IN, rrtype, answer, sizeof(answer));
#else
ret = res_query(label, C_IN, rrtype, answer, sizeof(answer));
--- a/common/dn_skipname.c
+++ b/common/dn_skipname.c
@@ -9,7 +9,7 @@
* return:
* 0 on success, -1 (with errno set) on failure.
*/
-int ns_name_skip(const u_char **ptrptr, const u_char *eom)
+static int ns_name_skip(const u_char **ptrptr, const u_char *eom)
{
const u_char *cp;
u_int n;

+ 4
- 2
ipv6/aiccu/patches/400-musl-compat.patch View File

@ -20,10 +20,12 @@
#include <linux/if_tun.h>
--- a/common/dn_skipname.c
+++ b/common/dn_skipname.c
@@ -1,5 +1,6 @@
@@ -1,6 +1,8 @@
#include <errno.h>
#include <resolv.h>
+#include <sys/types.h>
+#include <sys/types.h>
+
/* Ripped from glibc 2.4 sources. */
/*

Loading…
Cancel
Save