Browse Source

libreswan: fix compilation with musl

Added missing limits header. This is normally included in fortify-headers,
which I have disabled locally.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
118d129d6a
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 21 additions and 1 deletions
  1. +1
    -1
      net/libreswan/Makefile
  2. +20
    -0
      net/libreswan/patches/020-limits.patch

+ 1
- 1
net/libreswan/Makefile View File

@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libreswan
PKG_VERSION:=3.29
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://download.libreswan.org/


+ 20
- 0
net/libreswan/patches/020-limits.patch View File

@ -0,0 +1,20 @@
--- a/programs/pluto/connections.c
+++ b/programs/pluto/connections.c
@@ -34,6 +34,7 @@
#include <stdio.h>
#include <stddef.h>
#include <stdlib.h>
+#include <limits.h>
#include <unistd.h>
#include <netinet/in.h>
#include <sys/socket.h>
--- a/programs/pluto/rcv_whack.c
+++ b/programs/pluto/rcv_whack.c
@@ -36,6 +36,7 @@
#include <resolv.h>
#include <fcntl.h>
#include <unistd.h> /* for gethostname() */
+#include <limits.h>
#include <libreswan.h>
#include "libreswan/pfkeyv2.h"

Loading…
Cancel
Save