|
|
@ -1,6 +1,6 @@ |
|
|
|
--- a/configure.ac
|
|
|
|
+++ b/configure.ac
|
|
|
|
@@ -135,6 +135,7 @@ ARG_DISBL_SET([fips-prf], [disable
|
|
|
|
@@ -133,6 +133,7 @@ ARG_DISBL_SET([fips-prf], [disable
|
|
|
|
ARG_ENABL_SET([gcm], [enables the GCM AEAD wrapper crypto plugin.]) |
|
|
|
ARG_ENABL_SET([gcrypt], [enables the libgcrypt plugin.]) |
|
|
|
ARG_DISBL_SET([gmp], [disable GNU MP (libgmp) based crypto implementation plugin.]) |
|
|
@ -8,7 +8,7 @@ |
|
|
|
ARG_DISBL_SET([hmac], [disable HMAC crypto implementation plugin.]) |
|
|
|
ARG_ENABL_SET([md4], [enable MD4 software implementation plugin.]) |
|
|
|
ARG_DISBL_SET([md5], [disable MD5 software implementation plugin.]) |
|
|
|
@@ -1325,6 +1326,7 @@ ADD_PLUGIN([gcrypt], [s ch
|
|
|
|
@@ -1347,6 +1348,7 @@ ADD_PLUGIN([gcrypt], [s ch
|
|
|
|
ADD_PLUGIN([af-alg], [s charon scepclient pki scripts medsrv attest nm cmd aikgen]) |
|
|
|
ADD_PLUGIN([fips-prf], [s charon nm cmd]) |
|
|
|
ADD_PLUGIN([gmp], [s charon scepclient pki scripts manager medsrv attest nm cmd aikgen]) |
|
|
@ -16,7 +16,7 @@ |
|
|
|
ADD_PLUGIN([agent], [s charon nm cmd]) |
|
|
|
ADD_PLUGIN([keychain], [s charon cmd]) |
|
|
|
ADD_PLUGIN([chapoly], [s charon scripts nm cmd]) |
|
|
|
@@ -1458,6 +1460,7 @@ AM_CONDITIONAL(USE_SHA2, test x$sha2 = x
|
|
|
|
@@ -1480,6 +1482,7 @@ AM_CONDITIONAL(USE_SHA2, test x$sha2 = x
|
|
|
|
AM_CONDITIONAL(USE_SHA3, test x$sha3 = xtrue) |
|
|
|
AM_CONDITIONAL(USE_FIPS_PRF, test x$fips_prf = xtrue) |
|
|
|
AM_CONDITIONAL(USE_GMP, test x$gmp = xtrue) |
|
|
@ -24,7 +24,7 @@ |
|
|
|
AM_CONDITIONAL(USE_RDRAND, test x$rdrand = xtrue) |
|
|
|
AM_CONDITIONAL(USE_AESNI, test x$aesni = xtrue) |
|
|
|
AM_CONDITIONAL(USE_RANDOM, test x$random = xtrue) |
|
|
|
@@ -1707,6 +1710,7 @@ AC_CONFIG_FILES([
|
|
|
|
@@ -1733,6 +1736,7 @@ AC_CONFIG_FILES([
|
|
|
|
src/libstrongswan/plugins/sha3/Makefile |
|
|
|
src/libstrongswan/plugins/fips_prf/Makefile |
|
|
|
src/libstrongswan/plugins/gmp/Makefile |
|
|
@ -34,7 +34,7 @@ |
|
|
|
src/libstrongswan/plugins/random/Makefile |
|
|
|
--- a/src/libstrongswan/Makefile.am
|
|
|
|
+++ b/src/libstrongswan/Makefile.am
|
|
|
|
@@ -305,6 +305,13 @@ if MONOLITHIC
|
|
|
|
@@ -307,6 +307,13 @@ if MONOLITHIC
|
|
|
|
endif |
|
|
|
endif |
|
|
|
|
|
|
|