|
@ -1,18 +1,23 @@ |
|
|
--- a/src/twisted/python/_setup.py
|
|
|
--- a/src/twisted/python/_setup.py
|
|
|
+++ b/src/twisted/python/_setup.py
|
|
|
+++ b/src/twisted/python/_setup.py
|
|
|
@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, ob
|
|
|
|
|
|
|
|
|
@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
|
|
|
|
|
|
|
|
|
# The C extensions used for Twisted. |
|
|
# The C extensions used for Twisted. |
|
|
_EXTENSIONS = [ |
|
|
_EXTENSIONS = [ |
|
|
ConditionalExtension( |
|
|
|
|
|
|
|
|
- ConditionalExtension(
|
|
|
- "twisted.test.raiser",
|
|
|
- "twisted.test.raiser",
|
|
|
- sources=["src/twisted/test/raiser.c"],
|
|
|
- sources=["src/twisted/test/raiser.c"],
|
|
|
- condition=lambda _: _isCPython),
|
|
|
- condition=lambda _: _isCPython),
|
|
|
-
|
|
|
-
|
|
|
- ConditionalExtension(
|
|
|
|
|
|
|
|
|
ConditionalExtension( |
|
|
"twisted.internet.iocpreactor.iocpsupport", |
|
|
"twisted.internet.iocpreactor.iocpsupport", |
|
|
sources=[ |
|
|
sources=[ |
|
|
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c", |
|
|
|
|
|
@@ -240,7 +235,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
|
|
|
|
|
|
|
|
@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
|
|
|
|
|
"incremental >= 16.10.1", |
|
|
|
|
|
"Automat >= 0.3.0", |
|
|
|
|
|
"hyperlink >= 17.1.1", |
|
|
|
|
|
- "PyHamcrest >= 1.9.0",
|
|
|
|
|
|
"attrs >= 17.4.0", |
|
|
] |
|
|
] |
|
|
|
|
|
|
|
|
arguments.update(dict( |
|
|
arguments.update(dict( |
|
@ -21,11 +26,12 @@ |
|
|
use_incremental=True, |
|
|
use_incremental=True, |
|
|
setup_requires=["incremental >= 16.10.1"], |
|
|
setup_requires=["incremental >= 16.10.1"], |
|
|
install_requires=requirements, |
|
|
install_requires=requirements, |
|
|
@@ -249,6 +244,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
|
|
|
|
|
|
}, |
|
|
|
|
|
|
|
|
@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
|
|
|
cmdclass=command_classes, |
|
|
cmdclass=command_classes, |
|
|
include_package_data=True, |
|
|
include_package_data=True, |
|
|
+ exclude_package_data={'':['test/*']},
|
|
|
|
|
|
|
|
|
exclude_package_data={ |
|
|
|
|
|
- "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat"],
|
|
|
|
|
|
+ "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat", "test/*"],
|
|
|
|
|
|
}, |
|
|
zip_safe=False, |
|
|
zip_safe=False, |
|
|
extras_require=_EXTRAS_REQUIRE, |
|
|
extras_require=_EXTRAS_REQUIRE, |
|
|
package_dir={"": "src"}, |
|
|
|