|
|
@ -33,7 +33,7 @@ |
|
|
|
ifeq (,$(filter-out WIN%,$(OS_TARGET))) |
|
|
|
--- a/nss/coreconf/Linux.mk
|
|
|
|
+++ b/nss/coreconf/Linux.mk
|
|
|
|
@@ -108,11 +108,6 @@ LIBC_TAG = _glibc
|
|
|
|
@@ -113,11 +113,6 @@ LIBC_TAG = _glibc
|
|
|
|
endif |
|
|
|
|
|
|
|
ifdef BUILD_OPT |
|
|
@ -45,7 +45,7 @@ |
|
|
|
ifdef MOZ_DEBUG_SYMBOLS |
|
|
|
ifdef MOZ_DEBUG_FLAGS |
|
|
|
OPTIMIZER += $(MOZ_DEBUG_FLAGS) |
|
|
|
@@ -144,7 +139,8 @@ ifdef USE_PTHREADS
|
|
|
|
@@ -149,7 +144,8 @@ ifdef USE_PTHREADS
|
|
|
|
DEFINES += -D_REENTRANT |
|
|
|
endif |
|
|
|
|
|
|
@ -55,7 +55,7 @@ |
|
|
|
DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--gc-sections |
|
|
|
# The linker on Red Hat Linux 7.2 and RHEL 2.1 (GNU ld version 2.11.90.0.8) |
|
|
|
# incorrectly reports undefined references in the libraries we link with, so |
|
|
|
@@ -154,6 +150,7 @@ DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--
|
|
|
|
@@ -159,6 +155,7 @@ DSO_LDOPTS = -shared $(ARCHFLAG) -Wl,--
|
|
|
|
ZDEFS_FLAG = -Wl,-z,defs |
|
|
|
DSO_LDOPTS += $(if $(findstring 2.11.90.0.8,$(shell ld -v)),,$(ZDEFS_FLAG)) |
|
|
|
LDFLAGS += $(ARCHFLAG) -z noexecstack |
|
|
@ -63,7 +63,7 @@ |
|
|
|
|
|
|
|
# On Maemo, we need to use the -rpath-link flag for even the standard system |
|
|
|
# library directories. |
|
|
|
@@ -195,7 +192,7 @@ RPATH = -Wl,-rpath,'$$ORIGIN:/opt/sun/pr
|
|
|
|
@@ -200,7 +197,7 @@ RPATH = -Wl,-rpath,'$$ORIGIN:/opt/sun/pr
|
|
|
|
endif |
|
|
|
endif |
|
|
|
|
|
|
|