Browse Source

dcwifi: Update component versions

update package versions and hashes
remove bzero patches
remove uclibc++ patch
refactor directory structure
relocate mrmctl in menuconfig
update macremapper patch

Signed-off-by: Carey Sonsino <careys@edgewaterwireless.com>
Signed-off-by: Carey Sonsino <csonsino@gmail.com>
lilik-openwrt-22.03
Carey Sonsino 5 years ago
parent
commit
0f00bcb16e
23 changed files with 18 additions and 195 deletions
  1. +2
    -2
      kernel/macremapper/Makefile
  2. +2
    -2
      kernel/macremapper/patches/01_fix_nf_hooks.patch
  3. +2
    -2
      libs/libdcwproto/Makefile
  4. +2
    -2
      libs/libdcwsocket/Makefile
  5. +0
    -0
      libs/libdcwsocket/patches/02_fix_storage_size_error.patch
  6. +2
    -2
      net/dcstad/Makefile
  7. +2
    -2
      net/dcwapd/Makefile
  8. +0
    -0
      net/dcwapd/files/dcwapd.inc
  9. +0
    -0
      net/dcwapd/files/dcwapd.init.d
  10. +0
    -0
      net/dcwapd/files/dcwapd.uci
  11. +0
    -0
      net/dcwapd/files/start_dcwapd.sh
  12. +0
    -0
      net/dcwapd/files/stop_dcwapd.sh
  13. +0
    -0
      net/dcwapd/patches/01_add_uci_config_provider.patch
  14. +0
    -0
      net/dcwapd/patches/02_use_uci_config_provider.patch
  15. +0
    -0
      net/dcwapd/patches/03_add_uci_config_provider_to_Makefile.patch
  16. +0
    -14
      net/dcwifi/README.md
  17. +0
    -11
      net/dcwifi/dcstad/patches/01_replace_bzero.patch
  18. +0
    -40
      net/dcwifi/dcwapd/patches/04_uclibc++_fixes.patch
  19. +0
    -11
      net/dcwifi/dcwapd/patches/05_replace_bzero.patch
  20. +0
    -33
      net/dcwifi/libdcwproto/patches/01_replace_bzero.patch
  21. +0
    -45
      net/dcwifi/libdcwsocket/patches/01_replace_bzero.patch
  22. +0
    -24
      net/dcwifi/mrmctl/patches/01_replace_bzero.patch
  23. +6
    -5
      net/mrmctl/Makefile

net/dcwifi/macremapper/Makefile → kernel/macremapper/Makefile View File


net/dcwifi/macremapper/patches/01_fix_nf_hooks.patch → kernel/macremapper/patches/01_fix_nf_hooks.patch View File


net/dcwifi/libdcwproto/Makefile → libs/libdcwproto/Makefile View File


net/dcwifi/libdcwsocket/Makefile → libs/libdcwsocket/Makefile View File


net/dcwifi/libdcwsocket/patches/02_fix_storage_size_error.patch → libs/libdcwsocket/patches/02_fix_storage_size_error.patch View File


net/dcwifi/dcstad/Makefile → net/dcstad/Makefile View File


net/dcwifi/dcwapd/Makefile → net/dcwapd/Makefile View File


net/dcwifi/dcwapd/files/dcwapd.inc → net/dcwapd/files/dcwapd.inc View File


net/dcwifi/dcwapd/files/dcwapd.init.d → net/dcwapd/files/dcwapd.init.d View File


net/dcwifi/dcwapd/files/dcwapd.uci → net/dcwapd/files/dcwapd.uci View File


net/dcwifi/dcwapd/files/start_dcwapd.sh → net/dcwapd/files/start_dcwapd.sh View File


net/dcwifi/dcwapd/files/stop_dcwapd.sh → net/dcwapd/files/stop_dcwapd.sh View File


net/dcwifi/dcwapd/patches/01_add_uci_config_provider.patch → net/dcwapd/patches/01_add_uci_config_provider.patch View File


net/dcwifi/dcwapd/patches/02_use_uci_config_provider.patch → net/dcwapd/patches/02_use_uci_config_provider.patch View File


net/dcwifi/dcwapd/patches/03_add_uci_config_provider_to_Makefile.patch → net/dcwapd/patches/03_add_uci_config_provider_to_Makefile.patch View File


+ 0
- 14
net/dcwifi/README.md View File

@ -1,14 +0,0 @@
# Description
This directory contains package files for including Dual Channel Wi-Fi (dcwifi) components in an OpenWrt build.
# dcwifi Packages
The dcwifi packages can be found in the menuconfig in the following locations:
* dcstad: `Network -> Routing and Redirection`
* dcwapd: `Network -> Routing and Redirection`
* libdcwproto: `Libraries -> Networking`
* libdcwsocket: `Libraries -> Networking`
* macremapper: `Kernel modules -> Network Support` (listed as `kmod-macremapper`)
* mrmctl: `Utilities`

+ 0
- 11
net/dcwifi/dcstad/patches/01_replace_bzero.patch View File

@ -1,11 +0,0 @@
--- a/src/main.c
+++ b/src/main.c
@@ -190,7 +190,7 @@ main( int argc, char *argv[] ) {
rv = 1; /* failure unless proven otherwise */
/* first initialize and parse the command line */
- bzero(&cfg, sizeof(cfg));
+ memset(&cfg, 0, sizeof(cfg));
parse_cmdline(&cfg, argc, argv);
dcwloginfof("%s\n", "DCW Station Daemon Starting Up...");

+ 0
- 40
net/dcwifi/dcwapd/patches/04_uclibc++_fixes.patch View File

@ -1,40 +0,0 @@
--- a/dcw/controller.cxx
+++ b/dcw/controller.cxx
@@ -195,7 +195,7 @@ void Controller::OnStationUnjoin(const MacAddress& primaryMacAddr, const Message
//remove any channel bondings matching the provided data channel mac addresses
for (unsigned i = 0; i < m.data_macaddr_count; i++) {
const ::dcw::MacAddress dcaddr(m.data_macaddrs[i]);
- const ::dcw::TrafficPolicy::DataChannelMap::iterator dcmEntry = state.policy.dataChannels.find(dcaddr);
+ ::dcw::TrafficPolicy::DataChannelMap::iterator dcmEntry = state.policy.dataChannels.find(dcaddr);
if (dcmEntry == state.policy.dataChannels.end()) continue;
if (dcmEntry->second == NULL) {
dcwlogwarnf("Data channel MAC address %s on client %s is not currently bonded\n", dcaddr.ToString().c_str(), primaryMacAddr.ToString().c_str());
@@ -238,7 +238,7 @@ void Controller::OnStationAck(const MacAddress& primaryMacAddr, const Message& m
dcwlogdbgf("Got a station ACK from %s\n", primaryMacAddr.ToString().c_str());
// first make sure this client has actually sent a join first...
- const ClientStateMap::iterator client = _clients.find(primaryMacAddr);
+ ClientStateMap::iterator client = _clients.find(primaryMacAddr);
if (client == _clients.end()) {
dcwlogerrf("Got a client ACK without a station join from %s\n", primaryMacAddr.ToString().c_str());
Message reply(DCWMSG_AP_REJECT_STA);
--- a/dcwposix/processsignalmanager.cxx
+++ b/dcwposix/processsignalmanager.cxx
@@ -40,7 +40,7 @@ ProcessSignalManager::~ProcessSignalManager() {
}
void ProcessSignalManager::RegisterEventHandler(const int signum, ::dcwposix::ProcessSignalManager::EventHandler& eventHandler) {
- const SignalMap::iterator i = _sigmap.find(signum);
+ SignalMap::iterator i = _sigmap.find(signum);
if (i == _sigmap.end()) {
//be sure to preseve the old signal when inserting a new "unseen" signal
_sigmap[signum].insert(&eventHandler);
@@ -53,7 +53,7 @@ void ProcessSignalManager::RegisterEventHandler(const int signum, ::dcwposix::Pr
}
void ProcessSignalManager::UnRegisterEventHandler(const int signum, ::dcwposix::ProcessSignalManager::EventHandler& eventHandler) {
- const SignalMap::iterator i = _sigmap.find(signum);
+ SignalMap::iterator i = _sigmap.find(signum);
if (i == _sigmap.end()) {
dcwlogwarnf("Attempting to unregister handler %p non-registered process signal #%d\n", &eventHandler, signum);

+ 0
- 11
net/dcwifi/dcwapd/patches/05_replace_bzero.patch View File

@ -1,11 +0,0 @@
--- a/dcwlinux/macremapper_driver.cxx
+++ b/dcwlinux/macremapper_driver.cxx
@@ -174,7 +174,7 @@ void MacRemapperDriver::ApplyClientTrafficPolicy(const dcw::MacAddress& primaryA
}
//populate our remap ioctl()
- bzero(&re, sizeof(re));
+ memset(&re, 0, sizeof(re));
strncpy(re.filter_name, policy.trafficFilterProfile->GetName(), sizeof(re.filter_name));
memcpy(re.match_macaddr, primaryAddr.Value, sizeof(re.match_macaddr));

+ 0
- 33
net/dcwifi/libdcwproto/patches/01_replace_bzero.patch View File

@ -1,33 +0,0 @@
--- a/src/dcwproto.c
+++ b/src/dcwproto.c
@@ -20,12 +20,8 @@
-#ifdef WIN32
-#define bzero(ptr, size) memset(ptr, 0, size)
-#else
#include <config.h>
#include <strings.h>
-#endif
#include <dcwproto.h>
#include <string.h>
@@ -95,7 +91,7 @@ dcwmsg_marshal_sta_ack(struct dcwmsg_sta_ack * const output, const unsigned char
/* copy in the data ssid string bytes */
if (buf_len < copy_size) return 0;
- bzero(output->bonded_data_channels[i].ssid, sizeof(output->bonded_data_channels[i].ssid));
+ memset(output->bonded_data_channels[i].ssid, 0, sizeof(output->bonded_data_channels[i].ssid));
memcpy(output->bonded_data_channels[i].ssid, buf, copy_size);
buf_len -= copy_size;
buf += copy_size;
@@ -134,7 +130,7 @@ dcwmsg_marshal_ap_accept_sta(struct dcwmsg_ap_accept_sta * const output, const u
/* copy in the data ssid string bytes */
if (buf_len < copy_size) return 0;
- bzero(output->data_ssids[i], sizeof(output->data_ssids[i]));
+ memset(output->data_ssids[i], 0, sizeof(output->data_ssids[i]));
memcpy(output->data_ssids[i], buf, copy_size);
buf_len -= copy_size;
buf += copy_size;

+ 0
- 45
net/dcwifi/libdcwsocket/patches/01_replace_bzero.patch View File

@ -1,45 +0,0 @@
--- a/src/dcwsocket.c.linux
+++ b/src/dcwsocket.c.linux
@@ -100,10 +100,10 @@ dcwsock_open(const char * const ifname) {
}
/* sanitize our data structs... defensive */
- bzero(rv, sizeof(*rv));
- bzero(&ifr, sizeof(ifr));
- bzero(&sall, sizeof(sall));
- bzero(&sfp, sizeof(sfp));
+ memset(rv, 0, sizeof(*rv));
+ memset(&ifr, 0, sizeof(ifr));
+ memset(&sall, 0, sizeof(sall));
+ memset(&sfp, 0, sizeof(sfp));
/* open a raw socket... "ETH_P_ALL" says take EVERYTHING
(this means that it is IMPERATIVE to apply a filter)
diff --git a/src/dcwsocket.c.osx b/src/dcwsocket.c.osx
index abead10..75cda2f 100644
--- a/src/dcwsocket.c.osx
+++ b/src/dcwsocket.c.osx
@@ -90,10 +90,10 @@ dcwsock_open(const char * const ifname) {
}
/* sanitize our data structs... defensive */
- bzero(rv, sizeof(*rv));
- bzero(&dmx_desc, sizeof(dmx_desc));
- bzero(&proto_desc, sizeof(proto_desc));
- bzero(&snd, sizeof(snd));
+ memset(rv, 0, sizeof(*rv));
+ memset(&dmx_desc, 0, sizeof(dmx_desc));
+ memset(&proto_desc, 0, sizeof(proto_desc));
+ memset(&snd, 0, sizeof(snd));
/* open a "NDRV" socket... */
rv->fd = socket(PF_NDRV, SOCK_RAW, 0);
@@ -201,7 +201,7 @@ dcwsock_send( dcw_socket_t s, const void * const buf, const unsigned buf_size, c
fill out a link-level sockaddr cause we can only
use sendto() with PF_NDRV...
*/
- bzero(&sdl, sizeof(sdl));
+ memset(&sdl, 0, sizeof(sdl));
sdl.sdl_len = sizeof(sdl);
sdl.sdl_index = 0;
sdl.sdl_type = IFT_ETHER;

+ 0
- 24
net/dcwifi/mrmctl/patches/01_replace_bzero.patch View File

@ -1,24 +0,0 @@
--- a/userland/mrmctl/mrmctl.c
+++ b/userland/mrmctl/mrmctl.c
@@ -139,7 +139,7 @@ remap(int argc, char **argv) {
if (argc < 5) return 1; /* defensive */
/* initialize variables and put things into human-readable variable names */
- bzero(&re, sizeof(re));
+ memset(&re, 0, sizeof(re));
filter_name = argv[2];
match_macaddr = argv[3];
diff --git a/userland/mrmfilterparser/mrm_filter_conf_parser.c b/userland/mrmfilterparser/mrm_filter_conf_parser.c
index 926fa76..f5c54c1 100644
--- a/userland/mrmfilterparser/mrm_filter_conf_parser.c
+++ b/userland/mrmfilterparser/mrm_filter_conf_parser.c
@@ -319,7 +319,7 @@ filter_file_loadf(struct mrm_filter_config * const output, FILE * const f) {
return -1;
output->rules_active = 0;
- bzero(output->rules, sizeof(output->rules)); /* defensive */
+ memset(output->rules, 0, sizeof(output->rules)); /* defensive */
for (linenum = 1; fgets(buf, sizeof(buf), f) != NULL; linenum++) {

net/dcwifi/mrmctl/Makefile → net/mrmctl/Makefile View File


Loading…
Cancel
Save