Browse Source

libftdi1: Fix compilation with cmake 3.12

Applied a patch submitted upstream that fixes a compilation error with
cmake >= 3.12 Error: Unable to find 'swig.swg' [...] 'python.swg'

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
lilik-openwrt-22.03
Eneas U de Queiroz 6 years ago
parent
commit
0e9e060775
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      libs/libftdi1/Makefile
  2. +11
    -0
      libs/libftdi1/patches/101-use-findSWIG.patch

+ 1
- 1
libs/libftdi1/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libftdi1
PKG_VERSION:=1.4
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/


+ 11
- 0
libs/libftdi1/patches/101-use-findSWIG.patch View File

@ -0,0 +1,11 @@
--- a/python/CMakeLists.txt
+++ b/python/CMakeLists.txt
@@ -3,7 +3,7 @@ option ( LINK_PYTHON_LIBRARY "Link again
if ( PYTHON_BINDINGS )
# workaround for cmake bug #0013449
- if ( NOT DEFINED CMAKE_FIND_ROOT_PATH )
+ if ( NOT DEFINED CMAKE_FIND_ROOT_PATH OR CMAKE_VERSION VERSION_GREATER_EQUAL 3.0.0 )
find_package ( SWIG )
else ()
find_program ( SWIG_EXECUTABLE NAMES swig2.0 swig )

Loading…
Cancel
Save