Browse Source

python-curl: fix build on macos

setup.py detects macos (darwin) and adds -flat_namespace flag. This
flag is not compatible with GCC that is used to compile target.

This patch patch disables darwin detection

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
lilik-openwrt-22.03
Sergey V. Lobanov 3 years ago
committed by Rosen Penev
parent
commit
0e6a33a3a4
2 changed files with 16 additions and 1 deletions
  1. +1
    -1
      lang/python/python-curl/Makefile
  2. +15
    -0
      lang/python/python-curl/patches/100_macos_compat.patch

+ 1
- 1
lang/python/python-curl/Makefile View File

@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pycurl
PKG_VERSION:=7.44.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=2ce9905626d8ceafcbadee666e2f45397e29c7618ddcdc63fc22d85e5046c6d6


+ 15
- 0
lang/python/python-curl/patches/100_macos_compat.patch View File

@ -0,0 +1,15 @@
Support build on MacOS
This patch should be deleted after resolving https://github.com/pycurl/pycurl/issues/727
---
--- a/setup.py
+++ b/setup.py
@@ -347,9 +347,6 @@ manually. For other SSL backends please
if not self.libraries:
self.libraries.append("curl")
- # Add extra compile flag for MacOS X
- if sys.platform.startswith('darwin'):
- self.extra_link_args.append("-flat_namespace")
# Recognize --avoid-stdio on Unix so that it can be tested
self.check_avoid_stdio()

Loading…
Cancel
Save