Browse Source
Merge pull request #12861 from neheb/api
apinger: fix compilation with GCC 10
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
12 additions and
1 deletions
-
net/apinger/Makefile
-
net/apinger/patches/020-gcc10.patch
|
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
PKG_NAME:=apinger |
|
|
|
PKG_SOURCE_DATE:=2015-04-09 |
|
|
|
PKG_SOURCE_VERSION:=78eb328721ba1a10571c19df95acddcb5f0c17c8 |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE_PROTO:=git |
|
|
|
PKG_SOURCE_URL:=https://github.com/Jajcus/apinger |
|
|
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
--- a/src/apinger.h
|
|
|
|
+++ b/src/apinger.h
|
|
|
|
@@ -111,7 +111,7 @@ struct piped_info {
|
|
|
|
}; |
|
|
|
#endif |
|
|
|
|
|
|
|
-struct target *targets;
|
|
|
|
+extern struct target *targets;
|
|
|
|
|
|
|
|
extern int foreground; |
|
|
|
extern char *config_file; |