gerbera: update to 1.5.0lilik-openwrt-22.03
@ -0,0 +1,51 @@ | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=libnpupnp | |||
PKG_VERSION:=2.2.1 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||
PKG_SOURCE_URL:=https://www.lesbonscomptes.com/upmpdcli/downloads | |||
PKG_HASH:=da67d4c258d139d476af6b800926cd9cd09ba17d9e9fcfaebe3fb98241b32790 | |||
PKG_MAINTAINER:= | |||
PKG_LICENSE:=LGPL-2.1-or-later | |||
PKG_LICENSE_FILES:=COPYING | |||
PKG_INSTALL:=1 | |||
PKG_BUILD_PARALLEL:=1 | |||
include $(INCLUDE_DIR)/package.mk | |||
define Package/libnpupnp | |||
SECTION:=libs | |||
CATEGORY:=Libraries | |||
DEPENDS:=+libstdcpp +libexpat +libcurl +libmicrohttpd | |||
TITLE:=A C++ base UPnP library | |||
URL:=https://framagit.org/medoc92/npupnp | |||
endef | |||
define Package/libnpupnp/description | |||
npupnp (new pupnp or not pupnp ?) is an UPnP library derived from the | |||
venerable pupnp (https://github.com/pupnp/pupnp), based on its 1.6.x | |||
branch (around 1.6.25). | |||
endef | |||
TARGET_CFLAGS += -flto | |||
TARGET_LDFLAGS += -flto | |||
define Build/InstallDev | |||
$(INSTALL_DIR) $(1)/usr/include/npupnp/upnp | |||
$(CP) $(PKG_INSTALL_DIR)/usr/include/npupnp/upnp/* $(1)/usr/include/npupnp/upnp | |||
$(INSTALL_DIR) $(1)/usr/lib | |||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnpupnp.so* $(1)/usr/lib/ | |||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig | |||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnpupnp.pc $(1)/usr/lib/pkgconfig/ | |||
endef | |||
define Package/libnpupnp/install | |||
$(INSTALL_DIR) $(1)/usr/lib | |||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnpupnp.so.* $(1)/usr/lib/ | |||
endef | |||
$(eval $(call BuildPackage,libnpupnp)) |
@ -0,0 +1,53 @@ | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=pugixml | |||
PKG_VERSION:=1.10 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||
PKG_SOURCE_URL:=https://github.com/zeux/pugixml/releases/download/v$(PKG_VERSION) | |||
PKG_HASH:=55f399fbb470942410d348584dc953bcaec926415d3462f471ef350f29b5870a | |||
PKG_MAINTAINER:= | |||
PKG_LICENSE:=MIT | |||
PKG_LICENSE_FILES:=LICENSE | |||
CMAKE_INSTALL:=1 | |||
PKG_BUILD_PARALLEL:=1 | |||
include $(INCLUDE_DIR)/package.mk | |||
include $(INCLUDE_DIR)/cmake.mk | |||
define Package/pugixml | |||
SECTION:=libs | |||
CATEGORY:=Libraries | |||
TITLE:=pugixml | |||
URL:=https://github.com/zeux/pugixml | |||
DEPENDS:=+libstdcpp | |||
endef | |||
define Package/pugixml/description | |||
pugixml is a C++ XML processing library, which consists of a DOM-like interface | |||
with rich traversal/modification capabilities, an extremely fast XML parser which | |||
constructs the DOM tree from an XML file/buffer, and an XPath 1.0 implementation | |||
for complex data-driven tree queries. Full Unicode support is also available, | |||
with Unicode interface variants and conversions between different Unicode encodings | |||
(which happen automatically during parsing/saving). | |||
endef | |||
CMAKE_OPTIONS += \ | |||
-DBUILD_SHARED_LIBS=ON | |||
TARGET_CXXFLAGS += -flto | |||
define Package/pugixml/install | |||
$(INSTALL_DIR) $(1)/usr/lib/ | |||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpugixml.so* $(1)/usr/lib/ | |||
endef | |||
$(eval $(call BuildPackage,pugixml)) |
@ -0,0 +1,58 @@ | |||
# | |||
# This is free software, licensed under the GNU General Public License v2. | |||
# See /LICENSE for more information. | |||
# | |||
include $(TOPDIR)/rules.mk | |||
PKG_NAME:=spdlog | |||
PKG_VERSION:=1.5.0 | |||
PKG_RELEASE:=1 | |||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | |||
PKG_SOURCE_URL:=https://codeload.github.com/gabime/spdlog/tar.gz/v$(PKG_VERSION)? | |||
PKG_HASH:=b38e0bbef7faac2b82fed550a0c19b0d4e7f6737d5321d4fd8f216b80f8aee8a | |||
PKG_MAINTAINER:= | |||
PKG_LICENSE:=MIT | |||
PKG_LICENSE_FILES:=LICENSE | |||
CMAKE_INSTALL:=1 | |||
PKG_BUILD_PARALLEL:=1 | |||
include $(INCLUDE_DIR)/package.mk | |||
include $(INCLUDE_DIR)/cmake.mk | |||
define Package/spdlog | |||
SECTION:=libs | |||
CATEGORY:=Libraries | |||
TITLE:=spdlog | |||
URL:=https://github.com/gabime/spdlog | |||
DEPENDS:=+libfmt | |||
endef | |||
define Package/spdlog/description | |||
Very fast, header-only/compiled, C++ logging library. | |||
endef | |||
CMAKE_OPTIONS += \ | |||
-DSPDLOG_BUILD_SHARED=ON \ | |||
-DSPDLOG_BUILD_EXAMPLE=OFF \ | |||
-DSPDLOG_BUILD_EXAMPLE_HO=OFF \ | |||
-DSPDLOG_BUILD_TESTS=OFF \ | |||
-DSPDLOG_BUILD_TESTS_HO=OFF \ | |||
-DSPDLOG_BUILD_BENCH=OFF \ | |||
-DSPDLOG_SANITIZE_ADDRESS=OFF \ | |||
-DSPDLOG_INSTALL=ON \ | |||
-DSPDLOG_FMT_EXTERNAL=ON \ | |||
-DSPDLOG_FMT_EXTERNAL_HO=OFF \ | |||
-DSPDLOG_NO_EXCEPTIONS=OFF | |||
TARGET_CXXFLAGS += -flto | |||
define Package/spdlog/install | |||
$(INSTALL_DIR) $(1)/usr/lib/ | |||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libspdlog.so* $(1)/usr/lib/ | |||
endef | |||
$(eval $(call BuildPackage,spdlog)) |
@ -1,3 +1,4 @@ | |||
config gerbera config | |||
option enabled '0' | |||
option debug '0' | |||
option home '/tmp/gerbera' |
@ -0,0 +1,21 @@ | |||
--- a/src/util/string_converter.cc | |||
+++ b/src/util/string_converter.cc | |||
@@ -41,15 +41,15 @@ StringConverter::StringConverter(const std::string& from, const std::string& to) | |||
dirty = false; | |||
cd = iconv_open(to.c_str(), from.c_str()); | |||
- if (cd == reinterpret_cast<iconv_t>(-1)) { | |||
- cd = static_cast<iconv_t>(nullptr); | |||
+ if (cd == (iconv_t)(-1)) { | |||
+ cd = (iconv_t)(nullptr); | |||
throw_std_runtime_error(std::string("iconv: ") + strerror(errno)); | |||
} | |||
} | |||
StringConverter::~StringConverter() | |||
{ | |||
- if (cd != static_cast<iconv_t>(nullptr)) | |||
+ if (cd != (iconv_t)(nullptr)) | |||
iconv_close(cd); | |||
} | |||