Browse Source

tiff, giflib: removed for being abandoned

Signed-off-by: Steven Barth <steven@midlink.org>
lilik-openwrt-22.03
Steven Barth 10 years ago
parent
commit
0cb8ba433a
3 changed files with 0 additions and 194 deletions
  1. +0
    -59
      libs/giflib/Makefile
  2. +0
    -104
      libs/tiff/Makefile
  3. +0
    -31
      libs/tiff/patches/001-autoconf-compat.patch

+ 0
- 59
libs/giflib/Makefile View File

@ -1,59 +0,0 @@
#
# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=giflib
PKG_VERSION:=5.1.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/giflib
PKG_MD5SUM:=c7e9f1c10b755ab955156d4c1ac7fc5d
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
PKG_FIXUP:=autoreconf
PKG_REMOVE_FILES:=autogen.sh aclocal.m4
include $(INCLUDE_DIR)/package.mk
define Package/giflib
SECTION:=libs
CATEGORY:=Libraries
TITLE:=GIF libraries
URL:=http://sourceforge.net/projects/giflib
endef
define Package/giflib/description
giflib is a library for reading and writing gif images.
It is API and ABI compatible with libungif which was in wide use while
the LZW compression algorithm was patented.
endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += --enable-x11=no
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{lib,include}
$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/.libs/libgif.a $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libgif.la $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/*.h $(1)/usr/include/
endef
define Package/giflib/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/.libs/lib*so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,giflib))

+ 0
- 104
libs/tiff/Makefile View File

@ -1,104 +0,0 @@
#
# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=tiff
PKG_VERSION:=4.0.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.osgeo.org/libtiff
PKG_MD5SUM:=051c1068e6a0627f461948c365290410
PKG_FIXUP:=autoreconf
PKG_REMOVE_FILES:=autogen.sh aclocal.m4
PKG_INSTALL:=1
PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_libtiffxx
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/tiff/Default
TITLE:=TIFF
URL:=http://www.remotesensing.org/libtiff/
endef
define Package/libtiff
$(call Package/tiff/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE+= library
DEPENDS:=+zlib +libjpeg
endef
define Package/libtiffxx
$(call Package/tiff/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE+= library(c++ bindings)
DEPENDS:=+libtiff $(CXX_DEPENDS)
endef
define Package/tiff-utils
$(call Package/tiff/Default)
SECTION:=utils
CATEGORY:=Utilities
TITLE+= utilities
DEPENDS:=+libtiff
endef
TARGET_CFLAGS += $(FPIC)
define Build/Configure
$(call Build/Configure/Default, \
$(if $(CONFIG_PACKAGE_libtiffxx), \
--enable-cxx, \
--disable-cxx \
) \
--disable-lzma \
--enable-ccitt \
--enable-packbits \
--enable-lzw \
--enable-thunder \
--enable-next \
--enable-logluv \
--enable-mdi \
--enable-zlib \
--enable-jpeg \
--disable-old-jpeg \
--disable-jbig \
--without-x \
)
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{lib,include}
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
endef
define Package/libtiff/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiff.so.* $(1)/usr/lib/
endef
define Package/libtiffxx/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtiffxx.so.* $(1)/usr/lib/
endef
define Package/tiff-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libtiff))
$(eval $(call BuildPackage,libtiffxx))
$(eval $(call BuildPackage,tiff-utils))

+ 0
- 31
libs/tiff/patches/001-autoconf-compat.patch View File

@ -1,31 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,7 +25,7 @@
docdir = $(LIBTIFF_DOCDIR)
-AUTOMAKE_OPTIONS = 1.12 dist-zip foreign
+AUTOMAKE_OPTIONS = dist-zip foreign
ACLOCAL_AMFLAGS = -I m4
docfiles = \
@@ -48,7 +48,7 @@ EXTRA_DIST = \
dist_doc_DATA = $(docfiles)
-SUBDIRS = port libtiff tools build contrib test man html
+SUBDIRS = port libtiff tools build contrib
release:
(rm -f $(top_srcdir)/RELEASE-DATE && echo $(LIBTIFF_RELEASE_DATE) > $(top_srcdir)/RELEASE-DATE)
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -23,7 +23,7 @@
# Process this file with automake to produce Makefile.in.
-AUTOMAKE_OPTIONS = 1.12 color-tests parallel-tests foreign
+AUTOMAKE_OPTIONS = color-tests parallel-tests foreign
LIBTIFF = $(top_builddir)/libtiff/libtiff.la

Loading…
Cancel
Save