Browse Source

atftp: update to 0.7.5

Remove upstreamed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 2 years ago
parent
commit
0ad6384b5f
3 changed files with 2 additions and 24 deletions
  1. +2
    -2
      net/atftp/Makefile
  2. +0
    -11
      net/atftp/patches/01-missing-u_char-type-patch.patch
  3. +0
    -11
      net/atftp/patches/02-fix-invalid-read-in-tftp_send_request.patch

+ 2
- 2
net/atftp/Makefile View File

@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=atftp
PKG_VERSION:=0.7.4
PKG_VERSION:=0.7.5
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_HASH:=d3c9cd0d971dfc786d7a5f4055c35d4e66aafc8102ac03473ef225bdf7edb26a
PKG_HASH:=93c87a4fb18218414e008e01c995dadd231ba4c752d0f894b34416d1e6d3038a
PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
PKG_LICENSE:=GPL-2.0-or-later


+ 0
- 11
net/atftp/patches/01-missing-u_char-type-patch.patch View File

@ -1,11 +0,0 @@
--- a/tftpd.h
+++ b/tftpd.h
@@ -47,7 +47,7 @@ struct thread_data {
char *mc_addr; /* multicast address */
struct sockaddr_storage sa_mcast;
union ip_mreq_storage mcastaddr;
- u_char mcast_ttl;
+ unsigned char mcast_ttl;
/*
* Self can read/write until client_ready is set. Then only allowed to read.

+ 0
- 11
net/atftp/patches/02-fix-invalid-read-in-tftp_send_request.patch View File

@ -1,11 +0,0 @@
--- a/tftp_io.c
+++ b/tftp_io.c
@@ -64,7 +64,7 @@ int tftp_send_request(int socket, struct
buf_index += strlen(mode);
buf_index++;
- for (i = 2; ; i++)
+ for (i = 2; i < OPT_NUMBER; i++)
{
if (strlen(tftp_options[i].option) == 0)
break;

Loading…
Cancel
Save