Browse Source

Merge pull request #5014 from marcin1j/pr/20171025-nbd-fix-gnutls-dependecy

nbd: fix gnutls dependency
lilik-openwrt-22.03
Hannu Nyman 7 years ago
committed by GitHub
parent
commit
07fe7c1d77
3 changed files with 17 additions and 1 deletions
  1. +2
    -1
      net/nbd/Makefile
  2. +15
    -0
      net/nbd/patches/100-make-gnutls-test-optional.patch
  3. +0
    -0
      net/nbd/patches/101-fix-build-without-gnutls.patch

+ 2
- 1
net/nbd/Makefile View File

@ -51,7 +51,8 @@ define Package/nbd-server/description
endef
CONFIGURE_ARGS += \
--disable-glibtest
--disable-glibtest \
--without-gnutls
TARGET_CFLAGS += --std=gnu99 -DNODAEMON


+ 15
- 0
net/nbd/patches/100-make-gnutls-test-optional.patch View File

@ -0,0 +1,15 @@
--- a/configure.ac
+++ b/configure.ac
@@ -210,7 +210,11 @@ dnl ;;
dnl esac
dnl fi
-PKG_CHECK_MODULES(GnuTLS, [gnutls >= 2.12.0],[HAVE_GNUTLS=1],[HAVE_GNUTLS=0])
+AC_ARG_WITH([gnutls], AS_HELP_STRING([--with-gnutls], [Build with GnuTLS]))
+AS_IF([test "x$with_gnutls" = "xyes"], [
+ PKG_CHECK_MODULES(GnuTLS, [gnutls >= 2.12.0],[HAVE_GNUTLS=1],[HAVE_GNUTLS=0])
+])
+
if test x$HAVE_GNUTLS = x1; then
AC_DEFINE(HAVE_GNUTLS, 1, [Define to 1 if you have a GnuTLS version of 2.12 or above])
else

net/nbd/patches/100-fix-build-without-gnutls.patch → net/nbd/patches/101-fix-build-without-gnutls.patch View File


Loading…
Cancel
Save