Browse Source

Merge pull request #934 from openwrt/revert-927-python-push2

Revert "python: add patch to abort build on failed module build"
lilik-openwrt-22.03
Steven Barth 9 years ago
parent
commit
07961ce867
1 changed files with 0 additions and 21 deletions
  1. +0
    -21
      lang/python/patches/170-abort-on-failed-modules.patch

+ 0
- 21
lang/python/patches/170-abort-on-failed-modules.patch View File

@ -1,21 +0,0 @@
Abort on failed module build
When building a Python module fails, the setup.py script currently
doesn't exit with an error, and simply continues. This is not a really
nice behavior, so this patch changes setup.py to abort with an error,
so that the build issue is clearly noticeable.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -283,6 +283,7 @@
print "Failed to build these modules:"
print_three_column(failed)
print
+ sys.exit(1)
def build_extension(self, ext):

Loading…
Cancel
Save