Browse Source
davfs2: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
4 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
12 additions and
1 deletions
-
net/davfs2/Makefile
-
net/davfs2/patches/400-gcc10.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=davfs2 |
|
|
|
PKG_VERSION:=1.5.5 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
PKG_RELEASE:=3 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=@SAVANNAH/davfs2 |
|
|
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
--- a/src/dav_coda.c
|
|
|
|
+++ b/src/dav_coda.c
|
|
|
|
@@ -97,7 +97,7 @@ static unsigned int blocksize;
|
|
|
|
static size_t alignment; |
|
|
|
|
|
|
|
/* Send debug messages to syslog if != 0. */ |
|
|
|
-int debug;
|
|
|
|
+extern int debug;
|
|
|
|
|
|
|
|
|
|
|
|
/* Private function prototypes */ |