Browse Source

pdns-recursor: update to 4.4.2

Enable reproducible.

Remove upstreamed patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
0591ea432e
2 changed files with 4 additions and 24 deletions
  1. +4
    -3
      net/pdns-recursor/Makefile
  2. +0
    -21
      net/pdns-recursor/patches/300-boost-173.patch

+ 4
- 3
net/pdns-recursor/Makefile View File

@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pdns-recursor
PKG_VERSION:=4.4.1
PKG_RELEASE:=1
PKG_VERSION:=4.4.2
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
PKG_HASH:=f97fa34635d42c68acee5d4da9db0e5ff619fd49e62acace7b4bdb7ee3675698
PKG_HASH:=b0b97f49848a1758b64bc0b99a596c1583ea525477193f3c01905f5163a4f5cf
PKG_MAINTAINER:=James Taylor <james@jtaylor.id.au>
PKG_LICENCE:=GPL-2.0-only
@ -47,6 +47,7 @@ CONFIGURE_ARGS += \
--without-libsodium \
--with-protobuf \
--without-net-snmp \
--enable-reproducible \
--disable-silent-rules
CONFIGURE_VARS += \


+ 0
- 21
net/pdns-recursor/patches/300-boost-173.patch View File

@ -1,21 +0,0 @@
--- a/webserver.cc
+++ b/webserver.cc
@@ -36,6 +36,8 @@
#include "uuid-utils.hh"
#include <yahttp/router.hpp>
+using namespace boost::placeholders;
+
json11::Json HttpRequest::json()
{
string err;
--- a/ws-recursor.cc
+++ b/ws-recursor.cc
@@ -46,6 +46,7 @@
extern thread_local FDMultiplexer* t_fdm;
+using namespace boost::placeholders;
using json11::Json;
void productServerStatisticsFetch(map<string,string>& out)

Loading…
Cancel
Save