Browse Source

nginx: fix endianness issue #8988

Patch the auto/endianess file to use CONFIG_BIG_ENDIAN.

Signed-off-by: Peter Stadler <peter.stadler@student.uibk.ac.at>
lilik-openwrt-22.03
Peter Stadler 4 years ago
parent
commit
045adbeb66
2 changed files with 24 additions and 1 deletions
  1. +3
    -1
      net/nginx/Makefile
  2. +21
    -0
      net/nginx/patches/104-endianness_fix.patch

+ 3
- 1
net/nginx/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=nginx
PKG_VERSION:=1.17.7
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://nginx.org/download/
@ -361,6 +361,8 @@ ifeq ($(CONFIG_NGINX_LUA),y)
LUA_LIB=$(STAGING_DIR)/usr/lib
endif
CONFIGURE_VARS += CONFIG_BIG_ENDIAN=$(CONFIG_BIG_ENDIAN)
CONFIGURE_ARGS += \
--crossbuild=Linux::$(ARCH) \
--prefix=/usr \


+ 21
- 0
net/nginx/patches/104-endianness_fix.patch View File

@ -0,0 +1,21 @@
diff --git a/auto/endianness b/auto/endianness
index 1b552b6b..2b6f9ea4 100644
--- a/auto/endianness
+++ b/auto/endianness
@@ -12,6 +12,16 @@ checking for system byte ordering
END
+if [ "${CONFIG_BIG_ENDIAN}" != "y" ]; then
+ echo " little endian"
+ have=NGX_HAVE_LITTLE_ENDIAN . auto/have
+else
+ echo " big endian"
+fi
+
+return
+
+
cat << END > $NGX_AUTOTEST.c

Loading…
Cancel
Save