Browse Source

ctorrent-svn: fix musl compatibility

Add missing `sys/types.h` include to `strnstr()` replacement code in
`compat.c` in order to declare `ssize_t` type under musl.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
lilik-openwrt-22.03
Jo-Philipp Wich 9 years ago
parent
commit
0169cbd3a0
2 changed files with 12 additions and 2 deletions
  1. +2
    -2
      net/ctorrent-svn/Makefile
  2. +10
    -0
      net/ctorrent-svn/patches/400-musl-compat.patch

+ 2
- 2
net/ctorrent-svn/Makefile View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2008 OpenWrt.org
# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ctorrent-svn
PKG_REV:=322
PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://svn.code.sf.net/p/dtorrent/code/dtorrent/trunk


+ 10
- 0
net/ctorrent-svn/patches/400-musl-compat.patch View File

@ -0,0 +1,10 @@
--- a/compat.c
+++ b/compat.c
@@ -51,6 +51,7 @@ int snprintf(char *str, size_t size, con
#ifndef HAVE_STRNSTR
#include <string.h>
+#include <sys/types.h>
/* FUNCTION PROGRAMER: Siberiaic Sang */
char *strnstr(const char *haystack, const char *needle, size_t haystacklen)
{

Loading…
Cancel
Save